Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It seems like on Fedora 16 cabal isn't able to install scion-browser from hackage because of some incompatibilities with respect to Fedora's shared objects.

When I run cabal install scion-browser I get:

...
Loading package terminfo-0.3.2.3 ... <command line>: can't load .so/.DLL for:
   ncursesw (/usr/lib64/libncursesw.so: file too short)
cabal: Error: some packages failed to install:
scion-browser-0.2.8 failed during the building phase. The exception was:
ExitFailure 1

I already have all packages installed for ncurses and the required file exists, but it's not a binary or symbolic link and thus the installation fails:

bash-4.2$ cat /usr/lib64/libncursesw.so 
INPUT(libncursesw.so.5 -ltinfo)

I don't think replacing that file with a symbolic link to libncursesw.so.5 would be a great idea, but I can't think of any other way in order to get it installed. What should I do, please?

share|improve this question
    
anyone, please? –  Riccardo May 4 '12 at 12:37

1 Answer 1

As described here, GCC and GHC don't necessarily follow links in the same way. The fixed described worked for me.

cd /usr/lib
sudo mv libncurses.so libncurses.so.bak
sudo mv libncursesw.so libncursesw.so.bak
sudo ln -s /lib/libncurses.so.5 libncurses.so
sudo ln -s /lib/libncursesw.so.5 libncursesw.so

Since I was on a 64 bit Fedora box, I was moving things around in /lib64 and /usr/lib64

share|improve this answer
    
Thank you for your answer, but I already knew of this method (as I, perhaps too quickly, mentioned in my question). Symbolic links like those are likely to change with system updates soon or late, so that this would be only a temporary patch. I was searching for something to solve the problem once and for all. –  Riccardo Jun 23 '12 at 0:07
    
Oh, so you did. Good point. Though I thought that symbolic links were the standard way to alias library names. –  user52571 Jun 26 '12 at 12:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.