Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run cvlc on Ubuntu 10.04.4 in VirtualBox to stream a part of the desktop. However, I get the following error message.

lowerkey@c:~$ cvlc screen:// --screen-left=0 --screen-top=53 --screen-width=400 --screen-height=300 --screen-fps=15 --sout '#transcode{vcodec=theo,vb=800,scale=0.25,width=400,height=300,acodec=none}:http{mux=ogg,dst=:8181/graph.ogg}' --ttl=1
VLC media player 1.0.6 Goldeneye
[0x8f3b0d8] dummy interface: using the dummy interface module...
[0x8f46940] main stream out error: no sout stream module matched "http"
[0x8f3d350] stream_out_transcode stream out error: cannot create chain
[0x8f3d208] main stream output error: stream chain failed for `transcode{vcodec=theo,vb=800,scale=0.25,width=400,height=300,acodec=none}:http{mux=ogg,dst=:8181/graph.ogg}'
[0x8f3cdb8] main input error: cannot start stream output instance, aborting

Does someone know what's wrong here?

share|improve this question
    
Creating multiple answers won't help you get it solved. stackoverflow.com/questions/10161085/… –  Pedro Ferreira Apr 24 '12 at 13:08
    
Hey! Those were two different questions for two different issues. In this question here, no http module was found. In the SO version, it worked, but only for 15 seconds. Please read the questions carefully before merging them. –  lowerkey Apr 25 '12 at 15:47
    
sorry about that. it appears i should read the histories before criticizing... please accept my apologies. –  lowerkey Apr 25 '12 at 16:03
add comment

migrated from stackoverflow.com Apr 24 '12 at 18:39

This question came from our site for professional and enthusiast programmers.

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.