Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded a firefox tarball. When I try to extract Firefox-latest.tar.bz2 by:

sudo tar -jxvf Firefox-latest.tar.bz2

some errors appear on the terminal:

tar: .: Not found in archive
tar: Exiting with failure status due to previous errors

then I try to command:

sudo tar -jxf Firefox-latest.tar.bz2

still error!

so, I how do I solve this error ? and why does it happen?

share|improve this question

migrated from Apr 24 '12 at 20:32

This question came from our site for professional and enthusiast programmers.

and without sudo? Does it work? – Tomas Apr 24 '12 at 18:19
when I use root acount without sudo , but still error – YoungkingWang Apr 24 '12 at 18:25
up vote 2 down vote accepted

If the download was incomplete, the error should have been something like

$ tar jxvf firefox-12.0.tar.bz2

bzip2: Compressed file ends unexpectedly;
    perhaps it is corrupted?  *Possible* reason follows.
bzip2: Inappropriate ioctl for device
    Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

However, the output you describe is exactly what one gets if one executes:

$ tar jxvf firefox-12.0.tar.bz2 .
tar: .: Not found in archive
tar: Exiting with failure status due to previous errors

I believe you had a trailing . for some reason. Perhaps since you thought you had to specify extraction directory in that way (you can specify it with -C if you want, but . is the default).

share|improve this answer
the question has been solved , and you are right, I shouldn't specify extraction directory in that way , your way is right, thank you ! – YoungkingWang Apr 25 '12 at 9:27
@YoungkingWang: If this answer solved the question, you should mark it as correct by clicking the check mark next to it. This site relies on questions being marked as "answered" when they are resolved. – Daniel Andersson Apr 25 '12 at 9:38

Try re-downloading the file. tar -jxvf firefox-12.0.tar.bz2 worked on my system after downloading it from here:

share|improve this answer

was the download of the file complete without errors and the correct size? if you run "file Firefox-latest.tar.bz2" , what is returned?

share|improve this answer
the file Firefox is complete without errors because I can extract this file by using the gnome extract tool ,but I can't extract it on terminal, so how should i do – YoungkingWang Apr 24 '12 at 18:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .