Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I installed XAMPP and went to localhost on my web-browser and I get the XAMPP page, all seems well. I then went on no-ip and created a host: I went into my router settings to forward port 80 on the default gateway address and downloaded their dynamic IP software and added the host I created. I also made sure apache was running and that the conf file was listening on port 80 and the server was specified as When I try to go to on my browser it just spins for a second and then tells me it could not connect. Anyone know what I am missing here? Thanks!

share|improve this question

Usually port 80 is blocked by ISPs. Try using port 8080 or something off the wall.

Googling I found this tool to check to see if ports are blocked:

share|improve this answer
I tried switching to 8080, but still got same thing. Using that site I got the following error on port 80: "Reason: No route to host" – Mr_CryptoPrime Apr 25 '12 at 0:07

What you could do that works great is that if your router allows you to forward ports to other ports, like the name implies, you can open another port besides the common web ones that your ISP blocks. Some ISPs have the ports open but supply routers that otherwise won't. Try forwarding port 80 to something else, then make apache listen to that something else.

share|improve this answer

Quite simply, the domain name points to your public ip, which isn't accessible from inside your network.

You can test this a few ways - see if you can access the website with tor or other proxy, or check if its up with is it down for everyone or is it just me.

Also try accessing the web server using the server's internal/lan ip address.

If either of these work, you could just add a hosts entry for your domain name to access it.

share|improve this answer
I went onto my VM_Ubuntu and used Tor to try and access that site and it still failed to connect? – Mr_CryptoPrime Apr 25 '12 at 0:09
how about using the ip address of the system within the lan? – Journeyman Geek Apr 25 '12 at 0:41
Not sure what you mean, how would I do that? – Mr_CryptoPrime Apr 25 '12 at 1:05
well, find out the ip address of the server. then type in http://<ipaddress> in a web browser – Journeyman Geek Apr 25 '12 at 1:32
Oh yes, I already tried that a number of times...I think I am just going to give up, it's not worth it. Thanks for your help! – Mr_CryptoPrime Apr 25 '12 at 1:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.