Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The computer (study lab computer) that I am using has its USB disabled, hence I cannot run or copy the programs that I have in my pen-drive.

How can I run or view the contents in my pen drive.

OS: Linux Mint

share|improve this question
5  
Ask the administrator to have it enabled. –  Sathya Apr 25 '12 at 7:35
    
Already asked them but they are not willing to enable it. They are afraid that the computer might get infected by virus. But I always use Kaspersky AV at home and it didn't detect any virus. So my pen drive is virus free –  Failed_Noob Apr 25 '12 at 7:39
1  
Generally, if the functionality is disabled, it is disabled for a reason. –  Rilgon Arcsinh Apr 25 '12 at 7:41
1  
They have no way to know or verify that, however, without exposing themselves to unnecessary risk. It's not something that can be forcibly circumvented, nor should it be. You might want to consider a service along the lines of Dropbox instead. –  Rilgon Arcsinh Apr 25 '12 at 7:46
1  
You could make the point that allowing internet access opens a lot more avenues of spreading malware than a flash drive.. though that could backfire resulting in no internet access depending on how paranoid they are. –  Bob Apr 25 '12 at 8:02

1 Answer 1

Open the Windows Registry and open the following key HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Control\StorageDevicePolicies

Now add a new DWORD called WriteProtect and put the value as 0 to disable write privileges to the USB port. To reverse the step, either delete the WriteProtect REG_DWORD or toggle the value to 1 which will enable the port.

This trick will work only on XP SP2

share|improve this answer
    
I think they disabled the USB from BIOS, so will this trick work ? –  Failed_Noob Apr 25 '12 at 8:00
    
There is another way to Enable or Disable USB Port through Registry. Search for the Key “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UsbStor” Select the key UsbStor , double click on Start value. In “Value data” enter 4 to disable USB storage , or enter 3 to enable USB storage on windows system. –  Harish Apr 25 '12 at 8:09
1  
The question specified Linux Mint as the OS, not Windows..? –  Bob Apr 25 '12 at 8:16
    
Thanks I will try this method in my computer (win 7) when I get back home ^_^ –  Failed_Noob Apr 25 '12 at 8:17
2  
how in the world will you test it when you say you're using Linux? @Failed_Noob –  Sathya Apr 25 '12 at 9:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.