Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I replaced apache webserver with http(WINHTTP windows service) for use virtual hosts feature. But I was missing http(WINHTTP windows service) which I previously removed.I now want to reinstall this service for use print spooler.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Open up the Programs and Features item in Control Panel. On the left you'll see Turn Windows features on or off. Click on that.

A dialogue box called Windows Features appears, and inside there, you'll want to make sure that Internet Information Services (IIS) is checked or shaded. The World Wide Web Service under that option is what you're really looking for.

If you're sure this is installed, the next step is to make sure that the Web Server service is actually running. If you installed Apache, make sure it is now disabled, or configured for a port different to port 80 which IIS uses.

In Control Panel again, find Administrative Tools > Services, and look for World Wide Web Publishing Service. Make sure it is set to Automatic, and that it is Started. If it isn't started, right-click on it and click Start.

Assuming everything to this point is happy, it starts up and you will be able to serve web pages from IIS. If it fails, you'll need to troubleshoot. Usually IIS doesn't start if there is something else running on port 80 (e.g. Apache).

share|improve this answer

my http windows service was disabled. to enable this service. run this code in command line or Run

sc config http start= auto

print spool-er service depends on http service . if http service was disabled . print spooler(print service) unable to start.

share|improve this answer
    
+1. This is the command line version of what I suggested, and it's a great suggestion if you don't want to go through the UI. –  user3463 May 17 '12 at 17:03
    
2 hours of searching and following multiple suggestions with 4 restarts and this one line fixed everything. Thanks a million –  Onimusha Oct 4 '13 at 10:21
    
@MajidTaheri Thanks for posting your answer.. it works fine to fix the issue described here superuser.com/questions/176520/… +1 –  Krunal Jun 19 at 12:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.