Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I see "Unknown extension pipelining" in my Messages buffer, after sending an email with Emacs. I am wondering what is this telling me? I've done a couple of searches in the lisp source code and haven't seen where this message is generated. Can someone explain the origin of this message?

My email is sent successfully. I include below lines from the Messages buffer and also from the buffer "trace of SMTP session to localhost". I am queuing the mail before sending it. My setup is

GNU Emacs 23.3.1 (i386-mingw-nt5.1.2600) of 2011-03-10 on 3249CTO

and I have Cygwin routines in use.

from Messages buffer:

Loading c:/cygwin/home/Mail/queued-mail/2012-04-25_11!18!51_2.el (source)...done
220 smtp107.sbc.mail.mud.yahoo.com ESMTP
250-smtp107.sbc.mail.mud.yahoo.com
250-AUTH LOGIN PLAIN XYMCOOKIE
250-PIPELINING
250 8BITMIME
Unknown extension pipelining
235 OK, go ahead
250 OK , completed [2 times]
354 Start Mail. End with CRLF.CRLF
250 OK , completed
221 Service Closing transmission
Wrote c:/cygwin/home/Mail/queued-mail/index

from buffer trace of SMTP session to localhost:

Process SMTP deleted
220 smtp107.sbc.mail.mud.yahoo.com ESMTP

EHLO DELLLAPTOP

250-smtp107.sbc.mail.mud.yahoo.com

250-AUTH LOGIN PLAIN XYMCOOKIE

250-PIPELINING

250 8BITMIME

AUTH PLAIN [deleted]

235 OK, go ahead

MAIL FROM:

250 OK , completed

share|improve this question
add comment

1 Answer

A standard part of an SMTP session is the client saying EHLO and the server responding with its name followed by a list of supported SMTP extensions. The client can then choose to use or not use the listed extensions during the SMTP session.

The Emacs SMTP package smtpmail.el that you're using has an option to warn about SMTP extensions that the server offers in EHLO that the Emacs client doesn't support. This is an option primarily meant for developer use and so should not be enabled by default. Apparently it is enabled in your Emacs session, hence you see the warning about PIPELINING.

(setq smtpmail-warn-about-unknown-extensions nil)

in your .emacs file should get rid of the warnings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.