Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm unable to connect the Google Drive application to the Internet. I'm quite sure it's because of the proxy authentication. How can I fix this problem?

Windows 7 64 bit, proxy with authentication.

share|improve this question
up vote 10 down vote accepted

I'm behind a proxy at work which requires proxy authentication, and wouldn't work with Dropbox. So I followed the instructions in Allow Dropbox to authenticate with an NTLM proxy server to setup Dropbox with Cntlm (a kind of local machine proxy server). Happily you can make Google Drive use the same localhost proxy to connect to the Internet by simply changing your browser settings.

In Internet Explorer: Tools -> Internet Options -> Connections Tab -> LAN settings button.

Set the proxy server address to localhost and the port to whatever you configured Cntlm to use (3128 in my case).

Press OK to the settings and restart Google Drive. So long as your corporate firewall isn't blocking the actual web addresses for Google Drive you should now be OK, and you should still be able to browse.

share|improve this answer
Thx for this. Im having problems with determining the 'Domain' field in the configuration file. Any idea whats supposed to go there? – Urban Apr 26 '12 at 9:26
My work PC is on a domain group. You can probably work yours out by browsing your network (In windows 7 that's the "Network" icon you can see when open explorer), and changing the resulting window to "Show Details". There is a column called "Workgroup" the contents of which is probably your domain. It is mine. – DraxReaper Apr 26 '12 at 11:34
It worked with the instructions provided by DraxReaper. I have a Windows Domain environment. Thanks! – Iulian Dita Apr 30 '12 at 11:36
Well I havent tried this yet, but I guess this should work. @ditzah tried it and says it worked, so I think I should accept this. If this worked for anyone else, then do comment here. – Urban Apr 30 '12 at 12:07

In fact, Google says: "Google Drive for Mac/PC supports all unauthenticated proxies that are configured by the operating system."

I guess this is the same that "Google Drive for Mac/PC doesn't support authenticated proxies".

share|improve this answer

Google has information on what firewall rules to add, but to be honest, compared to Dropbox's simple proxy settings, this one is a pain.

Google Drive for your PC/Mac

Google Drive for the web

share|improve this answer

I work in a call center (in IT). We apply a default policy on our proxy so that our callers cannot access the internet (except for select sites) when they are working (they can during their breaks).

As a result anyone in the back office that wants to use the internet for http/s must authenticate with the proxy - which is of cause not supported by Google Drive.

My workaround was to set workstations that need access to Google Drive to bypass the proxy for, which is now allowed through the proxy without authentication.

I can't see that there is an option for people who have no option but to authenticate with a proxy though.

share|improve this answer

A crude workaround for online access:

If it's just the file listing that is blocked by the proxy and not the files themselves (like in my company), the following page will list your Google Drive files and allow you to open them:

This is a simple Google app script. It will ask for authorization. You can review the code by replacing exec with edit in the URL:

share|improve this answer

All you need is just add two keys at your registry. Navigate to the key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

and add String values called ProxyPass and ProxyUser. Fill them with yourProxyPassword and yourProxyUsername and be happy!

If you auth at proxy under domain user, use domainName\username for ProxyUser key.

Google Drive automatically detects proxy settings.

share|improve this answer
Why would you do this by hand instead of using the IE GUI to do it? – Ramhound Jul 30 '13 at 11:35
Ramhound: It is not possible to enter proxy user and password in IE GUI. – Al Kepp Apr 11 '14 at 21:42
Did not work in my case. – philcolbourn May 7 '14 at 6:46

A workaround is to disable proxy in Internet Explorer and instead to use a proxifier that supports HTTP proxies. You will need to know the network address of the proxy server.

I will use Proxycap in this example. It is easy to configure, and has a very nice option: "Use integrated Windows authentication".

Here are the step-by-step instructions:
1. In Proxycap follow these steps:
- Configuration -> Proxies
- Add HTTP proxy (set Type to HTTP)
- Add HTTPS proxy (same settings as for HTTP proxy, but Type=HTTPS)
- Configuration -> Rules
- Add "Force direct connection" rule for your LAN IP range, such as
- Add rule: action="redirect", proxy=[HTTP_PROXY], all programs, port=80
- Add rule: action="redirect" proxy=[HTTPS_PROXY], all programs, port=443
- Close the Configuration box by clicking OK.
2. In Internet Explorer follow these steps:
- Tools -> Internet Options -> Connections tab -> LAN settings button
- Uncheck all checkboxes

share|improve this answer

I have a solution for using Google Drive behind an authenticated proxy.

However, if may not fit your case, if you don't have the following: SSH access to a Unix machine and administrative privileges on your workstation

Please read my Howto here:

share|improve this answer
Welcome to Super User! It would be nice to include the essential parts of the answer here, and provide the link only for future reference. – slhck May 3 '12 at 20:26
This is just a description of setting up an ssl tunnel – Anton K Nov 6 '13 at 19:54

protected by Community May 1 '15 at 1:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.