Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In a text document, when you paste something from the clipboard, the new text is inserted into the document.

In a table document, when you paste, the existing cells are overwritten.

How can I get the behavior of text documents in Calc?

All my tables have four columns; all I want is that Calc makes room for N rows (when I have N rows copied) and then pastes.

share|improve this question
Have you tried using the "Paste Special" option? – Justin Pearce Apr 26 '12 at 19:43
That only allows to paste without styles. – Aaron Digulla Apr 27 '12 at 10:21
up vote 1 down vote accepted

You can achieve this using "Paste Special" (with CTRL+SHIFT+V or Menu "Edit" -> "Paste Special"), as Justin wrote in his comment. To insert the new rows above the selected row while retaining the style of the rows in the clipboard, make sure that the following paste options are selected:

  • Selection: "Paste all" (including Formats)
  • Shift cells: "Down" (use "Right" when pasting columns; leave the default "Don't shift" to overwrite existing, selected cells)

paste special with shifting existing cells

Using these settings, the inserted rows will keep their styles (both directly applied styles and cell styles).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.