Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

there. I'm an SSH/Cygwin noob, but want to use ssh via Cygwin to connect to a Windows 7 machine under a domain from ConnectBot (android).

I went through the ssh-host-config as described here: http://www.scottmurphy.info/open-ssh-server-sshd-cygwin-windows

When I connect to the server it says "Attempting 'password' authentication". I type the password and it says "Authentication method 'password' failed". This happens repeatedly until "Connection lost".

I've also tried loading the id_rsa key file into ConnectBot. It says "Authentication method 'publickey' with key 'id_rsa' failed".

If I connect locally I get something different. It asks for "passphrase for key..." which I enter and then connects successfully.

Can someone please help me troubleshoot this? I've Googled but I suppose I'm not looking in the right places. Thanks!!

share|improve this question
    
Can you post the last few lines from ssh -v ... ? – ckhan Apr 25 '12 at 22:25
    
@ckhan I think you mean on the server? (my workstation) If I open CYGWIN and type ssh -v it says this: "OpenSSH_6.0p1, OpenSSL 1.0.1a 19 Apr 2012" and then gives the usage arguments. Is that what you mean? :) – aikeru May 1 '12 at 20:13
    
OK I've managed to get a local account to work, but not a domain account. It also only works through password authentication. I'd really like my domain account to work by any means possible. – aikeru May 1 '12 at 20:15
    
Use your full ssh command line, but throw in -v as well. You'll get debug output. – ckhan May 2 '12 at 0:45
    
The client is "ConnectBot" which is an Android app so I do not have that option. I can try connecting from home though and see if I can reproduce the issue using -v and then supply the output. Thanks for your responses! Hopefully I will have something for you. – aikeru May 4 '12 at 19:13

You must log in to answer this question.

Browse other questions tagged .