Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having a problem with two of my computers, one Macbook Pro and one Macbook Air, both could not establish a connection from the Airport to the Airport Express base station. Even though with the base station I can connect other devices to it, such as the iPhones and iPads. I am sure it is not the problem of the base station. Suddenly today two of my computers refuse to connect to the Airport express base station. Does anyone have any hint to fix the issues?

I have tried to restart two computers, and also use the iPhone to enter the Airport Utility application and upgrade the firmware, everything is fine excepts that two mac computers refuse to connect.

I am having headaches for a while now, thanks in advance.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

After the whole day of combatting with the issue: from Apple website to Twitter, various blogs, no one has this problem.

I solved it finally by removing the character "@" in the password of the Airport and update its settings. It's so weird. Hope to help someone with the same issue.

Question remained: How is that all of my iPhones and iPads don't have this connection problem? and why only the Macbook Pro and Macbook Air encountered it?

UPDATE:

In fact, it was not completely solved by removing the "@" from the keyword, somehow when I updated the new password, the Airport Express issued a new radio range (I used Automatic mode) and my Macbook Pro worked, still the Macbook Air refused to connect. After some times switching to a fix range (one of the value in the range 0-15), I succeeded in getting all the devices to work. I guess it's the problem of the Wifi radio signal, choosing a fix Radio number forced the Airport Express to use a specific range, so it does not interfere with other routers in your building.

share|improve this answer
1  
I believe this is related to the security protocol, specifically WEP. I don't think WPA has the problem, and I also believe an iOS update fixed this as an issue a while ago. –  user3463 Apr 25 '12 at 22:40
    
I have not known that, I should've asked the question sooner. Thanks for pointing this out. You have any useful links? –  Hoang Pham Apr 26 '12 at 12:12
    
Unfortunately not, which is why I commented instead of answering formally. –  user3463 Apr 26 '12 at 22:18
    
I got the problem again, so this is not the issue with the '@' in the password. The internet connection on both computers sometimes are very slow, sometimes, it does not connect. –  Hoang Pham Apr 28 '12 at 12:21
    
I solved the issue, plz see the edited answer. –  Hoang Pham Apr 28 '12 at 16:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.