Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This morning, I got a notification that a newer version of Flash was released, so I downloaded it. Now, in Firefox, I can't use Flash on any site. Looking at the plugins list in the Add-ons Manager, Flash isn't even listed.

Things I've tried:

  • Reinstalling with the 32 and 64 bit versions of Flash
  • Switching from the Firefox beta channel to release channel and then reinstalling
  • Checking if it works in Chrome

The installer is trying to install for Firefox, as it's asking me to close Firefox during installation. In fact, after installation, I get the "Flash Installed Successfully" page. Flash is also working in Chrome, and the version info indicates that it's the one that I've been installing.

What else do I need to try? Is there a known issue with this release? If nothing else works, how can I roll back one version?

Edit: I'm using the latest version of both, and using Windows 7 Pro 64-bit. Firefox: 12.0 Flash: 11.2.something

Update: I've tried downloading the previous version from here, but none of the installers seem to work. The .msi installers fail with some cryptic error message, and the .exe installers complain that they're not the latest version, with no option to install anyway.

share|improve this question
    
FYI, Google Chrome ships with it's own version of Flash. Installing Flash for Firefox should not affect Chrome. Please edit your question to include the versions of Adobe Flash and Firefox involved. –  iglvzx Apr 25 '12 at 23:52
    
Also, which operating system? –  iglvzx Apr 26 '12 at 2:41
    
Give exact versions....11.2.something is useless. –  Ramhound Apr 26 '12 at 12:27
    
@Ramhound: It's kind of difficult to give exact version numbers when I can't even check it. Suffice it to say that it's the latest released build of 11.2, which is exactly what I said. Unless they've released a version in the past 6 hours that I've been at work... –  MBraedley Apr 26 '12 at 17:53

3 Answers 3

Why don't you try using system restore to turn your system and programs to a previous state? This way your browser should also have Flash installed

share|improve this answer

Try this. Uninstall Firefox and Adobe Flash and all other Adobe products.

Reboot your computer.

Head to www.ninite.com and use the tool to nab firefox, adobe flash, and whatever else you want. Ninite will manage everything, for downloading and installing both.

Ninite is nothing special about fixing apps, it's just a really convenient installation tool.

share|improve this answer
up vote 0 down vote accepted

I guess third time's the charm because it's working now. The latest version hasn't changed in nearly 2 weeks, so I don't know why it wasn't working yesterday.

Update: I ran into the same problem with my work machine. Between Firefox 12 and Flash 11.2, there must have been enough registry entry changes to necessitate a reboot or two.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.