Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have to visit a website in a regular basis that reminds me it was originally designed for Internet Explorer 8 and Mozilla Firefox 3.5.12 to 3.6.10. It displays a dialog box with that warning everytime I load the site. I tried reloading Chrome a few times so it'd ask me if I wanted to ignored those warnings but it didn't work.

What can I do to ignore this specific warning? Alternatively, what can I do to ignore any scripted dialog box?

share|improve this question
2  
That's the worst design decision I've ever heard...I'd mail the site creator in addition to any other solution you find. – Ben Brocka Apr 26 '12 at 0:37
    
can you provide a link? what kind of dialog box is this? maybe you could add specific css/js over a plugin to hide the dialog by default. – GNi33 Apr 26 '12 at 8:32
    
@BenBrocka Yep, it's like something from back in the days of Netscape Navigator and IE4... – Bob Apr 26 '12 at 10:02
    
@BenBrocka IBM ClearQuest behaves this way. They update the "allowed browser list" between versions, but that doesn't mean the OP's organization keeps it up-to-date. Anyway I know it's a late comment but just wanted to put the "ClearQuest" keyword on this page in case anyone is looking for a solution. – Oak Aug 1 '13 at 13:44
up vote 4 down vote accepted

To disable JavaScript on a specific site, add it to Chrome's JavaScript exceptions list.

Chrome JavaScript exceptions list

Visit this page: chrome://chrome/settings/contentExceptions#javascript > Enter host url > Under Behavior choose Block. Do note, this would also disable all other JavaScript feature on the specified URL.

Update: See if Better Pop Up Blocker helps.

Better Pop Up Blocker improves the default Google Chrome pop up blocker by blocking pop up windows opened by javascript & other annoyances that it misses like alert, prompt, and confirm boxes.

share|improve this answer
1  
Unfortunately I need many data that needs javascript to be retrieved in this site. Can it be set to block javascript only in the main page? When I tried inserting a longer adress it removes whatever goes after '.com/' – Renan Apr 26 '12 at 0:51
1  
I have updated my earlier answer. Check if it solves your issue. – Leo Apr 26 '12 at 9:36
1  
Thank you! The second extension has a lot more options and it was possible to block only the one at the front page by selecting "Prompt & alert boxes" only. – Renan Apr 26 '12 at 17:06
1  
The better pop up blocker extension link doesn't work. Has the extension been removed? – Asaf Dec 11 '14 at 19:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .