Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm rehosting a TCL/TK app from Solaris to a RHEL 6 sytem (GNOME/gdm). It runs fine on Solaris, but not RHEL. When this app uses send command, I get the following error:

X server insecure (must use xauth-sytle authorization) command ignored while executing "send myapp myproc myarg"

I understand TK send uses Xauthority, and that might be why I get this error. I just don't know how to fix it. I also learned that I can recompile TK with -DNO_SECURITY. I'm saving that as a last resort.

I'm running the app locally, so I'm not using xhost+. However, I tried using xhost+ and it still fails with the same error.

A google search turned up several solutions but they haven't worked on my RHEL6 system.

Any suggestions? Anyone have experience with this on RHEL6?

share|improve this question
    
Bueller, Bueller? –  urrutia Apr 27 '12 at 20:55
    
I fixed this by doing the following: –  urrutia May 2 '12 at 14:38
    
I fixed this when I noticed the xhost command returned "access control enabled, only authorized clients can connect<br>SI:localuser:username" Somewhere in my login, "SI:localuser:username" is being added. TK send fails because it doesn't like this. So, I tried "xhost - SI:localuser:username" to remove it. My tcl/tk app send code works now! However, I still get the same error if I login remotely, and set my display to the client I'm logging in from. In this case, I suspect x authorization needs to be modified. I'm still searching for a fix for the remote display. –  urrutia May 2 '12 at 14:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.