Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When opening certain macros, whether in design or run, I get ' Microsoft Access cannot find the object 'whatever the object name is>'. This only is on certain macros, but most of them work properly. Also, there are forms where there are click events tied to buttons. The events aren't even associated with the button anymore.

To me, this sounds like plain old corruption. Not sure how or why. Does this sound right or am I missing something. If it is, is there any way to recover?

share|improve this question
    
Is this is in one particular database file, or in several different files? Are you running with macros enabled and security level set correctly? Is this a new file or a file you've worked on for a while. Please provide some more information. –  user3463 Apr 27 '12 at 3:47
    
One access db file. This is an app that's worked for a long time and suddenly this happened. Most of the macros work so I don't think it's a security issue. –  asp316 Apr 27 '12 at 14:38
    
The file may just be corrupt then, as you suspect. Back it up, and then run the repair wizard on it. –  user3463 Apr 27 '12 at 18:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.