Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I configured my new router and noticed that WiFi connection is way slower than Ethernet connection.

Ethernet connection giving a download speed of ~60Mbps and upload speed of ~30Mbps while the Wifi only giving download speed of ~20Mbps and upload speed of ~15Mbps.

This is a new router with 802.11n and it says it support 300Mbps.

Here are the Wifi settings of the router,is there anything I can change to get higher speed :

http://oi50.tinypic.com/fymmax.jpg

http://oi46.tinypic.com/2we9sph.jpg

http://oi45.tinypic.com/2j43pqc.jpg

http://oi47.tinypic.com/315o3tv.jpg

share|improve this question
2  
Think this belongs superuser or systemfault. Not here –  kingchris Apr 27 '12 at 5:14
    
The main point is that the 300 Mb/s is the maximum signalling rate of the interface in case you can use two channels and there isn't any interference from outside sources. There is also considerable overhead due to the way the WiFi itself works. A considerable percentage of data being transmitted isn't the actual data you're sending. Instead it's data related to the maintenance of the connection itself. In wired Ethernet, that overhead is somewhat lower. –  AndrejaKo Apr 27 '12 at 5:43
1  
TKIP and 802.11n are incompatible on most hardware. Use WPA2-AES. Many devices drop to 54Mbps if you use TKIP. –  David Schwartz Apr 27 '12 at 7:03
2  
umanga, in the future, please never post the same question across multiple sites. This most likely leads to a mess like here. –  slhck Apr 27 '12 at 7:08
1  
Also @umanga I merged your migrated post into this one. If you ever ask a question on the wrong site by accident in the future, don't worry about reposting it - things tend to get migrated pretty quickly. –  nhinkle Apr 27 '12 at 7:19

3 Answers 3

up vote 5 down vote accepted

Those 15-20 megabit/sec throughputs you're seeing are fine for 802.11g, which is what (unbeknownst to you) you're actually configured to use here.

The IEEE 802.11n spec requires that you do WPA2 (AES-CCMP) or no security, and it requires that you do QoS (WMM). You've blocked yourself from doing 802.11n by doing TKIP-only and disabling WMM.

Also, by setting your channel width the 20MHz only, you've limited your N data rates to 144.4 mbps max. (Don't get me wrong, using 20MHz-wide channels is the right thing to do from a "good neighbor" perspective in the crowded 2.4GHz band. If you wanted to use Bluetooth on a client machine that was also doing 40MHz-wide 802.11n in the 2.4GHz band, it might not work out very well.)

Also note that the rule of thumb for Wi-Fi TCP throughput—on an app that uses TCP in an optimal manner—is 50-60% of the signaling rate. So even if you made the 3 changes I suggested above, and you truly had a good 300mbps N client machine (2 spacial streams in both directions, support for 40MHz channels in 2.4GHz) within good range of the AP, you shouldn't expect to see performance much greater than 150 megabits/sec (about 18 MebiBytes/sec).

By the way, please tell me that these settings (TKIP only, WMM off, 20MHz-only) were not the factory defaults for this product. That would be really sad if they didn't know better and were accidentally effectively disabling their marquee feature by default.

share|improve this answer
    
Your answer, is thought out, and w00talicious. –  SpacemanSpiff Apr 27 '12 at 17:52
    
@SpacemanSpiff There can be only one!</highlander> –  Spiff Apr 27 '12 at 18:33
    
@Spiff actually I changed the TKIP only,but others are factory default.By the way,I have "2.4Ghz(B)","2.4Ghz(N)","2.4Ghz(B+G)","2.4Ghz(G)" and "2.4Ghz(B+G+N)" for Band.I should go with "2.4Ghz(N)" right ? –  umanga Apr 29 '12 at 11:00
2  
@umanga No, you should go with B+G+N. See my comment on WesleyDavid's answer below. –  Spiff Apr 29 '12 at 16:36

Using say http://www.speedtest.net/ to verify speed You can generally expect only 50% of the channel speed for DL and less for UL, as it is a half duplex link.

You might try slowing down beacon rate to 1000mS. ensure no P2P services or Apps are running and verify your RSSI levels. Also try auto 20/40MHz

RSSI levels are often shown on some Wifi drivers in -dBm for signal and noise. You can't rely on bars.

With 54Mbps Wifi you need around -70dBm for full speed and -80dBm just to connect. Noise floor is usually -95dBm to -100dBm.

The higher the bit rate, the more bandwidth required for N speeds and the strong the signal must be.

I dont have all the answers and I know how to optimize the G rates, but not the N rates yet.

share|improve this answer
    
thanks for the tips –  umanga Apr 27 '12 at 7:18

Change your band from b+g+n to strict N. Otherwise it will be in protective mode and you'll never see the full N / MIMO speed. This requires your clients to be N and support MIMO, but you knew that.

share|improve this answer
    
thanks for the tip! I assume iPhone4S supports this ? –  umanga Apr 27 '12 at 5:01
1  
@umanga Let me clarify. The iPhone has 2.4Ghz N, not 5Ghz N. –  Wesley Apr 27 '12 at 5:17
2  
Most modern (< 6 years old) devices are at least G. If you can disable B do that. Also consider setting the channel manually. Choose the one with the least overlap from your neighbor's channel(s). en.wikipedia.org/wiki/List_of_WLAN_channels If you must overlap try to choose the one with the weakest foreign signal. –  Chris Nava Apr 27 '12 at 5:19
1  
5Ghz has more channels, shorter range, and less interference. –  David Schwartz Apr 27 '12 at 6:42
2  
This is bad advice. The slight theoretic speed increase you could get in "greenfield" N mode isn't usually achievable in reality, and many (most?) consumer implementations don't really bother implementing greenfield mode. So there's not much upside to trying to do greenfield. Unfortunately, there's a big downside to turning off B/G rates, and that is that even N clients usually fall back to B/G rates at range. So disallowing B/G means your N clients can't necessarily get as much performance at range as they could on a B/G/N network. –  Spiff Apr 27 '12 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.