Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Something is serving content on my port 80, but I don't know what process is doing this. Is there any way to find out what process is bound to which port(s)?

Update: This is the output of netstat... sadly, nothing appears to be binding port 80. Though my port 80 is still serving information. Is this impossible, or am I missing something? (see below)

Update: After running netstat -anbo and cross-referencing with the processes in the taskmanager, I've found out that skypekit.exe is binding my port 80. However, any further exploration of this problem will probably fall outside of the scope of this question. Just to add, Trillian was using ports 80 and 443 for skypekit.exe and its traffic.

PS D:\> netstat -anbo

Active Connections

  Proto  Local Address          Foreign Address        State           PID
  TCP                 LISTENING       6664
  TCP                LISTENING       1280
  TCP                LISTENING       6664
  TCP                LISTENING       4
 Can not obtain ownership information
  TCP               LISTENING       916
  TCP               LISTENING       1480
  TCP               LISTENING       1568
  TCP               LISTENING       980
  TCP               LISTENING       568
  TCP               LISTENING       956
  TCP               LISTENING       308
share|improve this question
Something is serving content on my port 80 ... my port 80 is still serving information What's telling you / giving you the impression you're serving content from that port? – Bob Apr 27 '12 at 14:30
See my answer, you need -anb not -b only! (a gives listening ports) – RedGrittyBrick Apr 27 '12 at 15:02
@RedGrittyBrick: I've updated it (though I had to add the -o flag to get PID's)... – Pepijn Apr 27 '12 at 19:53
up vote 14 down vote accepted

Try netstat -anb

C:\> netstat -anb

Active Connections

  Proto  Local Address          Foreign Address        State           PID
  TCP                 LISTENING       1724

Update: That a in -anb is there for a reason!

C:\> netstat /?

Displays protocol statistics and current TCP/IP network connections.

NETSTAT [-a] [-b] [-e] [-n] [-o] [-p proto] [-r] [-s] [-v] [interval]

  -a            Displays all connections and listening ports.
share|improve this answer
Where is netstat located? Because it's probably not on my PATH. – Pepijn Apr 27 '12 at 13:52
@Pepijn: %windir%/System32 ? – RedGrittyBrick Apr 27 '12 at 13:55
Right... something nuked my PATH... so I guess I found part of my problem. Thanks. ^^ – Pepijn Apr 27 '12 at 13:58
@Pepijn If system32 is out of your path, how did you run cmd? That's a little confusing. – Bob Apr 27 '12 at 14:31
@BOb: by Start search, where it just locates the cmd.exe file... I guess? ^^ – Pepijn Apr 27 '12 at 19:51

For future reference, Sysinternals has a lot of great tools for discovering what is happening on your machine. tcpview, for example, gives you real-time monitoring of TCP/UDP sockets, filemon can show you activity related to file accesses ... the list goes on.

share|improve this answer

It is most likely IIS, or Internet Information Services. If you are attempting to run Apache or some other HTTPD Server and are recieving the error Cannot bind to port 80, just host it on port 8080 and this will fix your problem.

To test this theory, open up your web browser and type in your IP address. See if The IIS Page pops up.

share|improve this answer
No it's not... though I guess you posted before I added the information that it was skypekit.exe. Still, I'm running Apache/PHP on 5252, 5353 and 5454... I was just curious, as I don't think any process should be listening on port 80. – Pepijn Apr 27 '12 at 19:56

One way is to use netstat -anbo

Active Connections

  Proto  Local Address          Foreign Address        State           PID
  TCP                 LISTENING       7908
  TCP                LISTENING       468
  TCP                LISTENING       4588

after stopping the vmware-hostd it should be up.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .