Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this new router, and I set up my connection like this:

  • 2.4 GHz B-G-N
  • Mode AP + WDS
  • Channel width: 40 MHz
  • Channel number: auto
  • Security disabled (just for now)

My network card is the Intel PRO/Wireless 2200BG

Anyone else can see and connect to the network, but I can't. I can also see other networks, just not mine.

Does anyone have any suggestions on how to solve this problem?

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

Are your old wireless card and your new router both the right version for your country (or really, for your radio regulatory agency domain)? For example, USA's "FCC" radio regulatory agency allows only channels 1-11, and FCC rules are used the the USA and Canada (and perhaps Mexico). Whereas Europe's "ETSI" agency allows channels 1-13. If your wireless card was an FCC model and your router was an ETSI model, and your router auto-selected channel 12 or 13, then it's not much of a surprise that your FCC card can't see it on those channels it's not allowed to use. Even if it's not an FCC vs. ETSI issue, I've seen some Wi-Fi devices that perform very poorly on certain channels because of internal RF/EMI interference from the host system, or other radio/antenna design problems. Try manually setting the channel on your router, and try a few different channels in different parts of the band (like 1, 6, and 11) to see if the channel matters.

Another possibility is that your old B/G card is getting confused by the N-specific options it's seeing in the Beacons and Probe Responses of your new router. Try temporarily turning off N support in your new router to try to make it look like a plain old B/G router, and see if your B/G card works better with it in that mode.

share|improve this answer
    
I'm in Europe . The channels I could choose are 1-13. It was in auto and started choosing manually. When I put it in 1 it appeared. THANK YOU MAN! YOU SAVED MY LIFE. REALLY THANK YOU!!! –  Giorgos Riskas Apr 27 '12 at 18:27
    
@GiorgosRiskas Glad I could help. I'm the kind of nerd that really wants to know what the real problem and the solution was, and whether my comments helped, so thanks for the follow-up. –  Spiff Apr 27 '12 at 18:36
add comment

You might have a profile that is using the same SSID but not properly configured, which could be blocking your ability to use that network. As a starting point, verify that all wireless network profiles are deleted, then reboot to try a full device re-initialization. Rogue profiles cause a lot of problems.

share|improve this answer
    
after I figured out the connection and everyone could connect except me, I formated my laptop and the result was exactly the same. I can see all the wifi conections except mine and all the others can see my connection and connect properly (even me with my ZTE). –  Giorgos Riskas Apr 27 '12 at 16:30
    
It might be the router not properly implementing the 802.11 spec, or it might have been setup to block/ban your MAC address on your WNIC. Consider upgrading/replacing the firmware on the router. I saw this with my D-Link router I had like 7 years ago, and I stopped using D-Link since. It may just be a crummy router. –  BloodyIron Apr 27 '12 at 16:35
    
No address blocked... I have already updated router's firmware and 802.11 is enabled. ANYONE else can find this connection. I'm really frustrated. It doesn't make any sense. –  Giorgos Riskas Apr 27 '12 at 16:50
    
Consider using DD-WRT if your router is supported. if not, consider replacing the device with another brand, such as Asus or Linksys. –  BloodyIron Apr 27 '12 at 17:41
    
problem solved. Thanks for your time guys! –  Giorgos Riskas Apr 27 '12 at 18:40
show 2 more comments

Can you also connect to other network with your laptop? Can you connect with the router if you connect LAN cable between your laptop and router? Maybe Firewall problems? Sometimes you need to configure your Firewall automatically, note that also router can or have Firewalls in build in.

Try open Network and Sharing Center, Try Troubleshoot problems Be sure to select valid Security type: "example WPA2-Personal" Be sure you enter right Encryption type; "example AES" Be sure to enter the right Network security key

Stil nothing works?

Try adding a network manually In network and sharing center, on the left you can see manage wireless networks. Select it and on the top you can see Add button. Select Add and then select Manually create a network profile.

Enter the network name, preferably the same as your routers name security type, encryption type and security key then select start this connection automatically. select next and go into your computers firewall and add this network.

restart your computer and it should connect if nothing else is wrong.

Still not working?

Try disabling Internet Protocol Version 6 (TCP/IPv6) Go into network and sharing center, manage wireless networks, and next to Add there is Adapter properties. Under Networking tab disable Internet Protocol Version 6 (TCP/IPv6). Restart your computer and try connecting again.

Also try resetting your WiFi.

Well I don't know any other solutions, good luck

share|improve this answer
    
Yes, I can connect to other networks and I can connect with ethernet too(I'm doing it right now). using windows firewall... nothing is blocked (even if I deactivate it nothing happens). The router has a firewall but nothing is blocked again. I disabled completely the security of network (nothing again). tried to add it manually (nothing). I'll try the last suggestions and answer after restart. Thanks for your time anyway. –  Giorgos Riskas Apr 27 '12 at 17:38
    
reseted everything. disabled Internet Protocol(no 6. Windows XP) still not working –  Giorgos Riskas Apr 27 '12 at 18:18
    
problem solved. Thanks for your time guys! –  Giorgos Riskas Apr 27 '12 at 18:40
add comment

I faced the exact problem. But solved by following the steps below.

Broadcasting SSID (if changing settings, change the SSID so it makes it easier to connect)

Use WPA security

mixed b and g mode(n if available)

use channels 1, 6 or 11. Most devices work better on these channels.

For me channel 11 worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.