Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to deploy .NET to some Windows XP machines using Group Policies and I was wondering wether I need to deploy older version of .NET to make newer version work. I want to install up to .NET 3.5.

And if I need to install previous versions of .NET to make 3.5 work, how can I make it so that .NET 2.x installs first using Group Policies?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

No, .NET 2.0, 3.0 and 3.5 are cumulative.

Other versions have varying forward-compatiblity:

  • .NET 1.1 apps will automatically run with only .NET 2.0+ installed. There may be some small compatibility glitches. That leads to:
  • .NET 2.0/3.0/3.5 apps can run with only 4.0 installed only if they have been set to do so (to avoid compatibility issues)
share|improve this answer
    
Thank you for your answer. I'll deploy 4.0 to one of our systems and see if it works! :-) –  Robbietjuh Apr 27 '12 at 22:28
    
.NET 4.0-only will probably have compatibility issues with apps written for previous versions unless you or the programmer has said "this app can run on 4.0 also". –  Mark Sowul Apr 27 '12 at 22:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.