Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've loaded xdebug 2.1.2 and in my phpinfo it seems to work however I want to know how can I verify that xdebug is listen to port 9000? Normally I would use a reverse shell to xdebug but with my vmware on my local box I want a normal remote session? I can ping my host from my virtual machine, I can connect to my webserver from my host to my virtual machine and also open an ftp session but I can't make my IDE connect to xdebug? I've already forward port 80 and 9000 from my vmnet8 to my host port?

Here is my vmware-netconfig:

I'm using VMnet8 in NAT mode. My subnet is 192.168.92.0. Ip of my guest is 192.168.92.128

I've forwarded port 80 and port 9000. However I can access port 21 from my host??? I can ftp to my guest os without port forwarding?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Enable xdebug.remote_log in your php.ini file first.

Try telnet hostip 9000

Make sure the xdebug.idekey=ECLIPSE_DBGP line is configured

share|improve this answer
    
Would it work when I use a reverse shell from my host to my virtual machine? I can't get that work, too. I use cygwin to open a reverse shell but Komodo can't connect to xdebug? The other problem is that Komodo does only listen to localhost but my vm is not localhost. There is also option to listen to debug proxy but that doesn't work either. –  Phpdna May 13 '12 at 14:20
    
You should not need the reverse shell. I am able to ping and telnet to my host windows 7 ip address where eclipse is. Restart apache and tell me what the remote log file says? –  jason May 13 '12 at 18:21
    
telnet 192.168.92.128:9000 doesn't work. I can ping and 192.168.92.128 the webserver but no telnet. I've forward the port 9000 in my vmnetwork config to no avail. Obviously there is no new line in my remote log. xdebug is running only when I load komodo inside my virtual machine and use localhost in the settings. I don't understand either. I also never achieved to run xdebug and komodo without a reverse shell with a REMOTE host. It's like komodo can only connect to port 9000 in localhost??? It makes me crazy. –  Phpdna May 13 '12 at 19:23
    
Telnet doesn't use colons. It's like this "telnet 192.168.92.128 9000" –  jason May 13 '12 at 23:21
    
Do you have Komodo? This seems to me a Komodo problem and not a telnet or vm problem? Do you have forwarded your port? –  Phpdna May 14 '12 at 5:30
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.