Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

With some combinations of paragraph font sizes, the spacing between paragraphs is much too large. I want to squeeze them together by giving the second paragraph a negative margin/spacing on top (or the first paragraph a negative margin/spacing on bottom).

In CSS, I could achieve the effect with a rule like below.

p.squeezeUpward
{
    margin-top: -6pt;
}

The setting that seems like it should work is Paragraph --> Indents and Spacing --> Spacing Before. If I could set this to a negative number, like -6 pt, I think it would achieve what I want. But negative numbers aren't allowed.

Note I'm not talking about paragraph styles with extra spacing. I'm talking about consecutive paragraph styles with no extra spacing where the "spacing" or "margins" of the fonts themselves create a large gap.

share|improve this question
    
Do you have an example of the fonts that demo the problem? Am curious so might try replicate it here and have a bash.. –  tanantish Apr 29 '12 at 8:08

2 Answers 2

Try Home - Paragraph - Line and Paragraph Spacing - On the drop-down you can click on " Remove Space After Paragraph" which should achieve what you want. Or, on the dropdown select "Line Spacing Options" and tick the check box "Don't add space between paragraphs of the same style".

share|improve this answer
    
Thanks. That doesn't seem to have any effect though. The paragraphs in this case are two different styles. I'm pretty sure the extra spacing/margin is coming from the fonts themselves, not any extra spacing specified anywhere in the style. It's easiest to see with large fonts. –  C. Dragon 76 Apr 29 '12 at 0:43
    
If you click on the Change Styles drop-down on the Home Ribbon there is a further paragraph spacing option that may work. –  BJ292 Apr 29 '12 at 11:10

What I finally found that seems to work reasonably well is setting the line spacing to an exact value.

Specifically, change Paragraph --> Indents and Spacing --> Line spacing from Single to Exactly and set At to an explicit point size. If you get small enough, you may need to add some Spacing After to make sure characters like lower-case "j" and "y" don't get clipped.

For example, I now have a paragraph style with 28 pt Segoe UI font where I set the line spacing to exactly 28 pt and the spacing after to 6 pt. This gets it very close to the paragraph right above it while still leaving a sizable margin below and plenty of room for "j" and "y" characters.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.