Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

enter image description hereclick to enlarge

I just installed the latest release of Google Chrome.

The problem is, when I open YouTube, Yahoo or some other sites, the browser instead of opening the site, displays some weird page full of random characters, and starts up a download of some application name "download". What do I do to fix it?

I am on windows 7 Home premium. PS: Now Google Chrome has started crashing. I have install a new copy which has no extensions, I have disabled my internet security software but still the problem is there..

share|improve this question
2  
Can you post a screenshot, please? Also, which operating system? – Ryan O'Hara Apr 29 '12 at 16:30

Something corrupts the arriving HTTP packet and the browser cannot understand it as a web page.

Most likely, you use some kind of web proxy or content filter or one is installed in your router or gateway. Antivirus software may be the culprit too.

share|improve this answer
    
I have installed Norton internet security antivirus. Can i make any changes to finish this problem – Umer Farooq Apr 29 '12 at 20:15
    
@UmerFarooq Try disabling the Internet security software. Confirm if that's the cause of the trouble. – Bibhas Apr 30 '12 at 6:34
    
But Firefox is working like charm no problems. But I want to use Chrome cuz its faster so now what !! – Umer Farooq May 4 '12 at 13:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .