Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'll start this with an example of what we are trying to achieve:

http://domain.ext where ".ext" is custom, in example .loc or .hrd or .one, ect.

My first impression is to create a zone for "loc" and just make sub-domains, but I don't want to go that route unless I have to. I just want for everyone in this network to type in the address I set for my dns. I created a zone "domain.loc" (where domain is an example for the name that I actually used)

  • I can ping "domain.loc" from the server hosting the dns with success

  • I have my netgear router with the dns setting configured to point first at my dns/web server "192.168.36.50" and secondary dns points to opendns.

  • I have dhcp enabled for all computers except the dns/web server which is static

  • I prefer to not go through the internet to resolve a local intranet domain name, hence the use of bind9 and lack of interest of paying to create a custom domain extension with ICANN

I'll update this post if I feel there's confusion.

The primary questions here are:

Is there a better way to use a custom domain extension on a local intranet?

In what ways can you create and use a custom domain extension on a local intranet?

share|improve this question
    
It's all perfectly valid, yet it annoys me that you constantly mention registering your own TLD as an option. Are you THAT rich ? :) –  Alex Apr 29 '12 at 18:02
    
No, I just want to avoid the obvious answer that you can register your own TLD with ICANN. I'm definitely not that rich, haha –  hdavis84 Apr 29 '12 at 18:13
    
Ok, you don't really need to avoid it, as you obviously can NOT register your own TLD. –  Alex Apr 29 '12 at 18:24
    
Anyhow, the setup you describe seems OK, what's the problem with it ? –  Alex Apr 29 '12 at 18:25
    
when I attempt to access the domain name (ex. domain.loc) from another computer on the network, opendns says it's not available. the primary dns for my network's dhcp is set to my dns/web server first, and opendns as second –  hdavis84 Apr 29 '12 at 18:47

1 Answer 1

up vote 1 down vote accepted

That's because your using opendns as the secondary DNS. You shouldn't mix internal and external DNS. Windows PCs especially will query whatever DNS server it feels like using and disregard the DNS order anyway.

If you drop the secondary DNS from the config on your router, it will work as planned. Your Bind9 machine should have its DNS servers set to OpenDNS, this way, it will forward any queries it doesn't have records (e.g. google.com) to OpenDNS to resolve. Setting up a secondary DNS is easy and probably a good idea in this scenario. Don't forget to flush your DNS cache on the machine before you start testing and use nslookup or dig to ensure your requests are going to the correct DNS server.

share|improve this answer
    
Thanks for the response, due to the time constraints I wasn't able to change the dns settings, but as soon as I get back to the server I will report how it went. Thanks very much for the response! –  hdavis84 Apr 30 '12 at 5:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.