Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had previously been using Ubuntu 11.10 and recently, Ubuntu 12.04. However, due to a stupid mistake on my part, I was forced to reinstall Windows 7.

One of a multitude of problems is that my download speeds seem to be slower on Windows 7.

On Ubuntu, I was reaching my ISP advertised speed of 25mbps. On Windows, I am stuck at 1.2mb/s. I have researched this reasonably but, I am completely lost. The problem, while looking online, seems to be window scaling.

http://en.wikipedia.org/wiki/TCP_window_scale_option

I just need a guide to disable this.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Answer was linked to in the Wikipedia article you linked to.

To disable auto-tuning, follow these steps:

Click Start, click All Programs, and then click Accessories.

Right-click Command Prompt, and then click Run as Administrator. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

At the command prompt, type the following command, and then press ENTER:

netsh interface tcp set global autotuninglevel=disabled

This command disables the Receive Window Auto-Tuning feature.

Close the Command Prompt window.

Restart the computer.

share|improve this answer
    
It seems as though the problem wasn't TCP window scaling. Regardless, you have answered my question. Thank you very much. –  Nyx Apr 30 '12 at 0:55
    
What was it? Just curious. –  Moab Apr 30 '12 at 1:15
    
No idea...yet. ;) I'll figure it out eventually. Though, TCP window limiting was a factor, disabling it only improved my download speed by 0.2 mb/s. –  Nyx Apr 30 '12 at 3:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.