Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I cannot upgrade my system anymore. I get the following error. What can I do to resolve this problem?

 apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  binutils: Depends: libc6 (>= 2.11) but 2.7-18lenny7 is installed
            Depends: libstdc++6 (>= 4.6) but 4.3.2-1.1 is installed
  cpp-4.6: Depends: libc6 (>= 2.11) but 2.7-18lenny7 is installed
  gcc-4.6: Depends: libc6 (>= 2.11) but 2.7-18lenny7 is installed
  libc-bin: Breaks: libc6 (< 2.10) but 2.7-18lenny7 is installed
  libc-dev-bin: Depends: libc6 (> 2.13) but 2.7-18lenny7 is installed
                Recommends: manpages-dev but it is not installed
  libc6-dev: Depends: libc6 (= 2.13-30) but 2.7-18lenny7 is installed
  libquadmath0: Depends: libc6 (>= 2.10) but 2.7-18lenny7 is installed

When I run apt-get -f install I get the following error

Preconfiguring packages ...
Setting up libgcc1 (1:4.7.0-3) ...
FATAL: kernel too old
/var/lib/dpkg/info/libgcc1.postinst: line 15:  3479 Segmentation fault      ldconfig
dpkg: error processing libgcc1 (--configure):
 subprocess post-installation script returned error exit status 139
Errors were encountered while processing:
 libgcc1
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
    
This might help a little - serverfault.com/questions/285511/…. – Bibhas Apr 30 '12 at 13:01
You might want to run `apt-get -f install' to correct these.
share|improve this answer
    
updated the question. new error – Andreas Linden Apr 30 '12 at 10:05
    
Please done use the code markup for emphasis ;) – Oliver Salzburg Apr 30 '12 at 10:13
    
@OliverSalzburg I just copied what he did. :P – Bibhas Apr 30 '12 at 12:04
    
@Bibhas: Oh, now I see it ;D My apologies. – Oliver Salzburg Apr 30 '12 at 12:05

Upgrade to wheezy folled by downgrade to squeeze made it. Was a bit tricky, had to remove and reinstall some packages for this to work.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .