Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I often work directly on a server in vim via ssh for small changes to sites, etc. However often if I input a lot of keypresses rapidly (such as holding down a page dn, scrolling my mouse wheel or pasting directly into the terminal from the local OS) the session will disconnect.

I'm not sure if this is down to the ssh binary, my terminal program or even the remote server, and was just wondering if there was any insight as to why this happens (and possible workarounds).

I alleviate most of the frustration by using a Screen session on the remote server, but it still is a pain to have to re-login every time I forget. For example is there a keypress buffer or something that I can enable which might solve this.

Set-up -

  • Local OS: Windows 7 x64
  • Remote OS: Fedora 13
  • Platform: Cygwin (Latest)
  • Terminal: MinTTY (Latest Cygwin bundled release)
share|improve this question
Does it happen immediately or does it time out? Does it happen if you use scp? does it occur just for the one server? the one client? – Michael Slade Apr 30 '12 at 12:04
Yeah, if I'm pasting into the terminal for example, some of the content will show up then the terminal will stall and after about 30s I'll get "Write Failed: Connection reset by peer" It mostly happens on a single server, but has happened in the past on other servers, I think it comes down to a char buffer somewhere becoming overloaded since the connection to the server is a bit flaky at times. I've used scp, I'll try that and update, but I've used SFTP fine before. I've not tried other clients in a while so I can't say if it happens in other situations. I'll install PuTTY and report back. – 9point6 Apr 30 '12 at 12:11
does it happen with any other protocols? say if you post a file to a web server? – Michael Slade Apr 30 '12 at 12:12
Nope it's just SSH via terminal afaik. I'd test another terminal protocol, but SSH is the only one available to me at the moment. – 9point6 Apr 30 '12 at 12:40
If you can scp large files at many kilobytes (or megabytes) per second to/from that server, then the problem isn't in the SSH protocol or the SSH server software, because scp uses the same protocol as ssh. The error "Connection reset by peer" means the server's TCP/IP stack sent a RST packet not that the SSH server closed the connection, so the server's stack was unable to hold open the connection for some reason. – Fran May 7 '12 at 14:06

I've tried pasting a load of stuff (10k lines) to two RedHat servers we have (one low latency one medium) using Putty and MinTTY but have not been able to replicate the problem.

I think trying putty would be the easiest and most likely to work.

share|improve this answer
PuTTY is likely the best answer. I've never had a problem with it. (Other than the usual.. "Ack! I'm on Windows!" issues...) – lornix Jun 30 '12 at 6:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .