Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a web service which needs to run on port 8731. I'm running Windows 7 x64 with XAMPP.

For privacy sake, let's assume my public facing IP, seen on, is 123.456.78.90:

  • // Works fine, loads the first <VirtualHost *:80> block in my vhosts
  • // Works fine, returns the wsdl
  • http://123.456.78.90 // Works fine, points to
  • http://123.456.78.90:8731/WebService/Namespace // Fails. Chrome cannot connect to 123.456.78.90:8731

In my router, I have port forwarding setup. Port 80 routes to I tried forwarding port 8731 to the same IP but it doesn't seem to make a difference. The port doesn't appear to be blocked by my router at all.

A test on yields a Success for port 80 and a Timeout for port 8731.

I also tried adding NameVirtualHost *:8731 to my vhosts and setting a <VirtualHost *:8731> block after enabling port forwarding for port 8731 to, and adding a Listen 8731 line in my httpd.conf, and it points to the correct vhost block.

Any ideas? Where can I look next?

share|improve this question
Can you check for blockings in windows firewall itself? Maybe Windows firewall blocking it. – The_aLiEn Apr 30 '12 at 13:53
*Slams head into wall. That was it. Just needed to tell the firewall to open that port specifically. Apache was in there allowed on all ports but I forgot this isn't apache. Post your comment as an answer and I'll accept. Thanks! – AlienWebguy Apr 30 '12 at 14:08
Edited the comment to make it more general answer: Firewall issue ;) – The_aLiEn Apr 30 '12 at 14:34
up vote 1 down vote accepted

Make sure any firewall isn't blocking that specific port along the way. Can you check for blockings in windows firewall itself? Maybe Windows firewall blocking it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.