Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just upgraded to Windows 7, and when after reinstalling my MS Office, I have an interesting error. When I click on a database, I get a popup message "There was a problem sending the command to the program", but the file application will still start and the proper database does get open.

Has anyone ever seen anything like this?

How would I go about investigating and then fixing this problem?

Note: I am not using Zone-Alarm. Most online searches on this problem return various sites and MSKB articles discussing problems using Zone-Alarm

SOLVED: Thanks to Mihi --- After renaming the Registry key from ddexec to NOddeexec, the problem went away -- still not sure why the DDE is broken, but works well enough for me now

share|improve this question
    
Are you clicking on the database file itself or a shortcut to it? –  JohnFx Sep 18 '09 at 23:09
    
I am clicking on the database file itself. –  Noah Sep 19 '09 at 15:50
    
Are you using any other firewall? –  harrymc Sep 20 '09 at 15:08
    
Only the standard Win-7 included firewall. Also, the file is on my local drive in a sub-directory of MyDocuments –  Noah Sep 20 '09 at 15:28
    
Are you logged as administrator? Have you tried to turn UAC completely off? –  harrymc Sep 20 '09 at 15:51

11 Answers 11

up vote 2 down vote accepted

Had this issue but only with specific office products (i.e. Excel and Word would work but Access would fail with the message).

Here is how I fixed the issue in Windows 7 - 64 Bit (Possibly would work for Vista as well).

[NOTE: This solution involves editing your system registry. Please be careful as incorrectly editing the registry could corrupt your operating system!]

Using Registry Editor provided with Windows 7 (Regedit)

  • Check the extension key in the registry for the current association
  • HKEY_CLASSES_ROOT.mdb (I was dealing with Office 2007 but just locate the file extension entry you are interested in).
  • Check the (Default) value entry, then find the key in HKEY_CLASSES_ROOT it refers to (in my case this is Access.MDBFile).
  • Locate the sub key "shell" and delete it (see warning above)
  • Go back to and locate a file you wish to open, you will now be asked to choose a program to open it with. At this point locate the office program you wish to use to open the file and your done.

Checking my settings after doing this, noticed that the Access.MDBFile key in the registry had changed, it now had a CLSID key that pointed to the new home of the file association.

  • The sub key CLSID (in my case HKEY_CLASSES_ROOT\Access.MDBFile\CLSID, (Default) value was {73A4C9C1-D68D-11D0-98BF-00A0C90DC8D9}).
  • Used find to search for the CLSID (excluding curly brackets), remember to check under "Look at", "Keys" before performing the search (in my case found key HKEY_CLASSES_ROOT\Wow6432Node\CLSID{73A4C9C1-D68D-11D0-98BF-00A0C90DC8D9} but this could differ, my example is for 64 bit system handling a 32 bit version of Office 2007).
  • This reference is to the "Microsoft Office Access Application" that uses an In-process server to launch the application, using this method fixed my Access file associations.
share|improve this answer

Has anyone ever seen anything like this?

probably, since the error is documented in this MSKB article. it also has been mentioned in connection with ZoneAlarm.

share|improve this answer
    
I read those MSKB articles, but I don't use ZoneAlarm at all. It is a vanilla Win7 upgrade –  Noah Sep 16 '09 at 15:33
    
i don't have a solution, only pointing out that this error is quite common. but the answers are vague at best, seems to be one of those windows mysteries. :) –  Molly7244 Sep 16 '09 at 16:10

Log of activities:

I used Control Panel to change the Office 2007 installation, removing Access. Then using Control Panel, I added Access back. This had no effect on the problem.

I used Control Panel to repair the Office 2007 installation, then rebooted. This had no effect on the problem.

NOTE:

  • When I double click on the file, the problem occurs. When I right click, choose OpenWith and select Access, the problem does not occur.
  • This problem does not occur with Excel
share|improve this answer

Basically, this error appears if a file type is set up to use DDE (an old Windows-3.x-style communication protocol between applications running on the same computer) to open a file.

You will find it in file types in folder options of explorer (maybe somewhere else on Windows 7, but there will be some place where an administrator can set up which files to open with which programs).

When that "Use DDE" option is checked, Windows will first check whether the program is already running, and then (if it does) send it a DDE message (consisting of 3 texts, "Application", "Topic" and "Message"). This way it can avoid opening the program again even if it is already running. When the program is not running, it is just started normally. In case the DDE connection fails, the dialog you mention will appear and it will just start the program again normally.

So, the easiest fix is just to disable "Use DDE" for the file extension of your database (I guess .mdb). The only drawback of this: When you open a database and Access is already running, Windows will open a second instance of Access, which will in turn notice the first one and send the DDE message and exit after that. I. e. you are unneccessarily starting Access so that it can close again at once. But nowadays with fast CPUs and hard disks, I guess this is acceptable :-)

The more complex fix would be to check whether something is wrong in these settings (like wrong topic or wrong application) and fix that. Doing that would require you having access to another (maybe virtual) machine where opening files work so that you can compare the DDE configuration.

EDIT: According to this website, that tab was dropped in Vista. You could always do it manually in the registry: Look up HKEY_CLASSES_ROOT\.mdb for its default value (say it is mdbfile) and then look at that default value (HKEY_CLASSES_ROOT\mdbfile\shell\open\ddeexec).

share|improve this answer
    
I have access to another working machine. Where would I look to compare the DDE configuration? –  Noah Sep 22 '09 at 17:55
    
@Noah: In Windows Explorer, go to Tools -> Folder Options. Click the File Types tab. Find the mdb filetype. Select Advanced. Click on the "Open" action and select "Edit...". Bear in mind that if you're comparing this to another workstation, the other workstation might be using DDE just fine, but since your workstation isn't, try unchecking it and seeing if that works (possibly after a reboot). –  Andy Sep 23 '09 at 12:46
    
Windows 7 does not have a "Folder Options" tab –  Noah Sep 24 '09 at 16:16
    
According to mydigitallife.info/2008/06/20/…, that tab was dropped in Vista. You could always do it manually in the registry: Look up HKEY_CLASSES_ROOT\.mdb for its default value (say it is mdbfile) and then look at that default value (HKEY_CLASSES_ROOT\mdbfile\shell\open\ddeexec)... –  mihi Sep 24 '09 at 20:56
    
Can you add this last comment to your answer. –  Noah Sep 25 '09 at 16:11

I am not shure but could it be that in access this option to hear on DDE-Calls is disabled. i saw this option in Word and excel too but do not remember access. Maybe a security issue to better disable this...

share|improve this answer

In the installed office folder. right click on excel/winword .exe and select properties. Select compatibilty tab and make sure "run this program in compatibility mode for" is UNCHECKED.

share|improve this answer

Fix It from MS - There was a problem sending the command to the program.

(Excel opens with an error or without displaying a workbook)
This article was previously published under Q211494.

share|improve this answer

Here is the solution I found for Access 2002. It will be similar for other versions of Access.

  1. Open Access
  2. Click on Tools
  3. Click on Options
  4. Click on the Advanced Tab
  5. Uncheck the box next to "Ignore DDE requests"
  6. Close Access

It worked for me! No more "There was a problem sending the command to the program." error.

For the different versions of Access, the "Ignore DDE requests" option may be stated a little differently, but you should be able to find something comperable.

I hope this helps other who have the same problem.

share|improve this answer

Here is the fix for Access 2007:

  • Click the Office "Coin" in top left corner of Access.
  • Select "Access Options"
  • Select the "Advanced" option
  • Scroll to the botton and uncheck the "Ignore DDE Requests"

Should open fine without having to mess about with the registry.

share|improve this answer

If this error is showing up when using Office with Windows 7 with an Access ADP file, the problem may be due to a firewall.

Windows XP with Access 2007 uses SMB for communication to the MSSQL Server. Windows 7 with Access 2007 uses TCP (standard SQL port) port 1433 to try to get to the MSSQL Server. If you have Windows Firewall, or a hardware firewall blocking port 1433, it tries 3 times to make a connection and when it fails the third time, it switches to SMB and works normally.

Open TCP port 1433 on the server running the SQL Server.

I have not found out why Windows 7 uses TCP port 1433 first instead of SMB like XP, and I have not found out how change it.

share|improve this answer
    
what's the relation for the mysql into this word / excel app anyway? I didn't get what you mean... sorry. –  gumuruh Apr 24 at 7:51

I don't use Access, but I recently started encountering the same problem with Excel and Word (2007) on Win7 while opening documents from the "Recent" list in my Start menu (using the arrow on the Word Shortcut menu item). The DDE checkbox solution didn't apply to me, as it was already unchecked (and doesn't exist in Word, as far as I know).

I stumbled upon a solution that seems to have fixed the problem for me: When I opened the Properties dialog for the document shortcut (from the context menu; see screenshot below), I noticed that the "Opens With" field had somehow been changed to another application other than Microsoft Word. Clicking the "Change" button enabled me to re-associate this file with "Microsoft Office Word" (without having to mess with the registry).

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.