Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't enable Aero effects on Windows 7 Enterprise edition. I'm at a loss of how to enable it. Thanks for the help! Let me know whether I could include anything else which would be helpful! Here are a few helpful screenshots...

This is where you should normally enable this feature This is where you should normally enable this feature

Here's what that window should look like enter image description here

This is just another example of me not being able to do anything with this This is just another example of me not being able to do anything with this

Here's the real error Here's the real error

The driver I have here is for remote desktop. I'm not using this remotely, but on my laptop. the driver

share|improve this question
1  
Not to be snarky, but I think you should check your eyesight - it looks like the mirror driver is there. 'LANDesk Remote Control Mirror Driver'. Are you connected remotely to this system? That mirror driver shouldn't be used unless you are, so this should be working. –  Shinrai Apr 30 '12 at 17:21
    
Ah! I'm embarrassed! Yeah, there it is. I'm not connected remotely to this system, it's my lenovo t420 thinkpad laptop. –  kentcdodds Apr 30 '12 at 17:23
    
I updated my post to reflect my bad eyesight. Haha. –  kentcdodds Apr 30 '12 at 17:28
    
Well, for whatever reason, it thinks it's rendering with that mirror driver. It's possible that simply having it installed is enough to disable Aero. You could disable it in Device Manager (or uninstall the remote software) as a test. –  Shinrai Apr 30 '12 at 17:30
    
That worked! If you want to submit an answer I'll accept it to give you the points. Thanks :) –  kentcdodds Apr 30 '12 at 17:33
show 1 more comment

3 Answers

up vote 1 down vote accepted

For whatever reason, it thinks it's rendering with that mirror driver. It's possible that simply having it installed is enough to disable Aero - it might have hooks in place all the time even though you're not actually using it, which are enough to throw Windows off.

You could disable the mirror driver in Device Manager, or entirely uninstall the remote software. Of course, this will inhibit your remote functionality, so it's a tradeoff.

share|improve this answer
    
This should not be, however, LogMeIn Uses a mirror driver as well and will only disable while it is connected. –  Jeff F. Apr 30 '12 at 17:56
    
@JeffF. - You're right that it shouldn't be doing this. It strikes me as a bug, or an unexpected interaction, or just poorly written software. –  Shinrai Apr 30 '12 at 18:13
add comment

Guaranteed fix if indeed you are using LogMein: log in either from your tablet or another computer and then log off.

I noticed my machine no longer using Aero and going through the exact process posted here. Instead of disabling the driver, I logged on from my iPad and logged back off and watched my Win 7 Ult desktop refresh with Aero functioning normally.

share|improve this answer
add comment

You may not have performed a Windows Experience Rating test, this will always prevent you from enabling Aero.

1) start menu, rlight click on computer, go to properties.

2) Click on "this computer has not yet been rated", or "Windows Experience Index", and run the assessment, or re-run it. Since mine has been assessed, I can't describe the exact way to go if you haven't.

3) When it is complete, try Aero again.

share|improve this answer
    
This is not true - the rating module will trip anytime you make a significant change but that won't shut off Aero in and of itself (as a test, try just swapping GPUs sometime). I will say that I've seen RUNNING the WER actually kick it back on, though! –  Shinrai Apr 30 '12 at 17:49
    
I have swapped GPUs before, it's always a good idea to re-assess your system once hardware has been swapped. There is no guarantee this is the issue, but due to a lack of information from the OP, this seems a logical starting point. –  BloodyIron Apr 30 '12 at 17:51
    
And that's why I didn't downvote this; because while I don't think it works here it's not really bad advice. :) –  Shinrai Apr 30 '12 at 18:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.