Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since upgrading to Snow Leopard, any QuickTime movies embedded in a web page auto play after a short amount of time. I recall that there used to be a QuickTime plugin setting to turn this off, however it appears as if the new version of the plugin doesn't have any preferences at all.

Does anyone know how to disable QuickTime autoplay in Snow Leopard?

Firefox 3.5 is my default browser. I haven't tested this in Safari, but I bet that it happens there as well.

share|improve this question

1 Answer 1

This blog post may be useful,
The Curious Case of Quicktime Autoplay in Safari.

Ever since I installed Snow Leopard, I’ve been battling with a strange bug in Safari. If I go to a website with several embedded videos, they all start playing simultaneously. I’d been in the head of the page with no video present in the current view when suddenly all the audio streams start playing and overlapping each other.

I’ve been searching Google, combing the Apple discussion boards with no clue or direction on how to fix this bug. Then this morning I had an idea. I thought it must be a Safari plugin… and it was. I’ve been using a flash blocker called ClickToFlash and it was the culprit. When it intercepts YouTube videos it sets them all to Autoplay and they all start playing.
Thankfully, it’s been reported as a bug in the ClickToFlash support board.

there is a support ticket to fix the autoplay bug in ClickToFlash 1.5fc2
and there is now a workaround as well.

You can get the ClickToFlash settings at that post.

There is also this Apple thread discussing how to Turn of Quicktime AutoPlay which refers to that post.


Besides my comment to yours, there is this QuickTime HTML Scripting reference that might interest you.
Appears that if the 'AUTOPLAY' attribute is set to 'true' while embedding Quicktime content,
it cannot be disabled. Though, I think there should be a way to get by that...

share|improve this answer
    
Unfortunately I don't think that's my issue. I'm using Firefox (sorry that I didn't put that into my question, I have updated it now). I use FlashBlocker (works similar to ClickToFlash, as I understand it). My problem is with QuickTime movies autoplaying, not Flash movies. –  Andy Sep 17 '09 at 11:08
    
Hmm, there is a recent thread about Disabling Quicktime plugin AutoPlay at the forums, again in Safari reference... discussions.apple.com/thread.jspa?threadID=2072190 –  nik Sep 17 '09 at 12:11
    
I saw that thread, too. Didn't seem very helpful, though. :( –  Andy Sep 17 '09 at 17:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.