Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried the similar posts' solutions but I couldn't get it to work.

I have tried:

  1. Releasing and renewing the WAN.
  2. Unplug the router, wait for a night and plug it in again.

I have looked on the local-area connection settings located in the control panel->network, in order to change the IPv4 or IPv6 properties but I had two of them so I didn't know which one to change, and even when I will know, I don't know what I should write in the subnet mask and the IP address itself.

So my general question is how can I change my current public static IP address (WAN)?

I'm on Windows 7.

My router is HOTBOX SAGEMCOM F@ST TM 3184 it's kind of new so i don't know if you know it... or it Docsis 3 (it's my internet provider special router but on their site its saying its Docsis 3 so maybe that's the real name)

share|improve this question
add comment

closed as not a real question by Chris S, studiohack Apr 30 '12 at 19:03

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

"Static IP" is too vague. If you mean PUBLIC Static IP, that is either set on your router, or set by your ISP. Since I don't know your router I can't guide you. If it's your ISP you need to contact them.

If you mean LOCAL Static IP (local to your computer), first you need administrative privileges. If you do not have administrative privileges you will never be able to change this.

Assuming you do have network privileges, follow these steps:

1) Start Menu, type in "view network connections", go to the corresponding link

2) Right click on the adaptor you want to change the IP for (I'm going to assume you know how to determine which one you want to change), go to properties.

3) In the list, locate "Internet Protocol Version 4", click on it to highlight it, and hit properties. Double clicking works too.

4) In the General tab:

a) If there are values in the fields, AND "use the following IP address" is selected, clear out the values, do the same for DNS just below. Then switch the IP and DNS to obtain automatically.

b) If there are values in the fields, AND "use the following IP address" is NOT selected, select use the following address, clear out the fields, do the same for DNS, switch both back to automatic.

5) Switch to the "Alternate Configuration" tab. If it is set to automatic, and nothing is in the fields, you're good. If there are values set, make sure user configured is set, clear them out, then switch back to automatic.

6) Click OK to save settings, then OK again. Your network card should now be trying to acquire an IP address through DHCP. Give it a few minutes.

If this does not resolve it, you have a deeper static setting, which requires much further troubleshooting.

share|improve this answer
    
i've edited the post i need the public static ip my router is HOTBOX SAGEMCOM F@ST TM 3184 it's kinda new so i dont know if you know it... or it Docsis 3 (it's my internet provider special router but on their site its saying its Docsis 3 so maybe that's the real name) –  Dan Barzilay Apr 30 '12 at 18:54
2  
If i'm understanding correctly. If this device is your modem AND router provided by your ISP, you should call them as they may be limiting your access to the device. If this device is a separate router from your modem, then try resetting it to defaults. If you still have issues after that, best give your ISP a shout. –  BloodyIron Apr 30 '12 at 19:03
add comment

Releasing and renewing only applies for a dyanmic IP address, not a static one. When you release/renew, you are asking a DHCP server for an IP address again.

Static IPs are set one the computer or device itself. If the IP is truly "static" the DHCP server won't know, and if there isn't a DHCP server, then there's nothing "out there" to give you an IP address.

If you are on a Windows system and looking in the Network Connections control panel (easiest way to get there is go to the start menu and type ncpa.cpl then ENTER) - it's typical to have more than a couple network adapters. On Windows, the "wired" network connection (your ethernet cable, presumably connected to your modem) is typically named "Local Area Connection" - that's the one you want to set the IP on.

It's very likely unless your ISP has told you otherwise that it has given you an IPv4 address. I would for simplicity DISABLE IPv6 (uncheck the box next to Internet Protocol Version 6) - and go ahead and disable the Link Layer Topology stuff (both of them) as well.

The IP itself - only your provider can tell you that. The netmask is likely 255.255.255.255, 255.255.255.254, or 255.255.255.252.

For DNS server I would just use Google's public DNS - specify 8.8.8.8 and 8.8.4.4, but you can use your ISP provided values if you want.

share|improve this answer
3  
Your answer doesn't take into account that you can program static IP address leases into the DHCP server (typically by mapping a client MAC address or other DHCP Client ID to a static IP). If your DHCP server is configured to always give you the same address, it's still a static (static means "unchanging") address, even though it's provided over DHCP. –  Spiff Apr 30 '12 at 18:47
    
Thanks but what should i put in Default gateway? –  Dan Barzilay Apr 30 '12 at 18:50
    
Your router's IP (Say 192.168.1.1) –  gparent Apr 30 '12 at 19:10
    
@Spiff: Yes, DHCP reservations... I prefer not to use the term static in that situation IMHO - it still could change if the DHCP server is reconfigured but a host-set static IP will not change unless the user changes it. Anyway... not sure if an ISP that provides a customer with a static IP would issue a "static" IP via a DHCP reservation (never purchased a static IP from a provider before). –  ultrasawblade Apr 30 '12 at 19:41
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.