Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
  • Router: Cisco WRVS4400N secured with WPA2
  • WAP: Cisco WAP4410N

My router was working well but the signal too weak in distant rooms.

So, I purchased a WAP4410N but I'm unsure about the configuration.
From reading the product docs, I understand these to be the best options:

  1. Access Point -- Wired connection through built-in Ethernet port. (Not Desired)
  2. Wireless WDS Repeater
  3. Wireless Client / Repeater (What is difference from WDS Repeater?)
  4. Wireless WDS Bridge

Desired Result:
Simply extend the network. As a laptop is carried from room to room, the laptop should switch to the strongest signal seamlessly, without the user doing anything manually.

No matter where I am, the laptop should see all other computers. Also, I prefer that the WAP would not require a wired Ethernet connection (that is, I would like the WAP to receive/repeat the router's wireless signal so that no ethernet cable is required).

  1. Which of those above 4 settings is best for achieving my desired outcome?
  2. What should the SSID be on the WAP? Same as on the router?
  3. Should both the router and WAP be on the same channel? (I suspect not, but included docs sound like they should be..?)
  4. Should both the router and the WAP have the same wireless security setting (WPA2) and passphrase?

Is there anything else I should know?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

If you want to extend the wireless network wirelessly, you need to put them on the same channel. Otherwise, the extender won't be able to talk to both the base and its clients.

A WDS bridge won't work because a WDS bridge can't have its own clients. It only bridges wired clients. For WDS repeating, you don't have to use the same SSID, but it's recommended. It will make roaming work more seamlessly. For a client repeater, they must be on the same SSID or the extender won't become a client of the base.

The difference between a client repeater and a WDS repeater is that a WDS repeater does things right and a client repeater fakes it. You have to fake it if the base access point doesn't support WDS or for some reason you can't (or don't want to) configure it in the base access point. For example, if your base will disable 802.11n if you enable WDS, you may prefer not to enable it.

A WDS repeater acts much like a regular Ethernet bridge. Things should work just the same as if the clients were local. A client repeater has to impersonate its clients to the access point so the access point thinks they're its own wireless clients. This can break protocols other than IP and can break if you have more than one IP subnet on the network. However, for most simple configurations, it works fine.

Roaming from one access point to the other should work seamlessly with WDS. There may be a connectivity hiccup with a client repeater because the hardware address appears to change.

share|improve this answer
    
One of the most clear and concise answers I've ever read. Thank you. I promise to return to this post and upvote when my rep > 15. –  gibberish May 1 '12 at 0:16
add comment

Got it working, but it was a bit of an effort to make WDS roaming work correctly. Here's what worked for me:

  1. Same SSID on Router/AP and WAP
  2. Different channel on each (otherwise a laptop's wireless NIC won't switch over to the WAP)
  3. Same security and password (I used WPA2 Personal, successfully)
  4. I had to give the WAP a hard-wired Ethernet connection. My preference was to simply repeat the wireless signal, but I was unsuccessful getting that to work.
  5. On my router (WRVS4400N), I had to enable a setting called "Allow wireless signal to be repeated by a repeater." (Found under Wireless menu, WDS submenu)
  6. My WAP (WAP4410N) has a menu called AP MODE. The setting that worked is "Wireless WDS Repeater" and it requires that I specify the MAC address of the router/AP.

Phases: Initially, I set the WAP to use a different channel and different SSID and got that working. In this config, I had to manually disconnect from the Router SSID, and connect to the WAP one. But it worked, and it proved I was getting Internet access through the WAP, via the router/AP. Only then did I set them to the same SSID and have successful roaming.

Final Result: As I move from area to area, I watch the main router's wireless signal grow weaker, until it automatically jumps over to the WAP and goes to 5 bars.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.