Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am connecting to a cisco VPN router via PPTP on my windows 7 Ultimate machine. Like most VPN's, it connects just fine but also redirects all of my traffic through the VPN. I really only need RDP access when I use this specific VPN and maybe later down the road a few other services.

My local network is using 192.168.1.0/8 and the remote network is using 10.10.10.0/8.

Is there any way to make this vpn conneciton only use RDP (program or specific ports) via windows firewall or something else?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Can you uncheck "Use default gateway on remote network" in Properties for the VPN connection? It is hidden away in Networking, IPv4 Properties, Advanced, IP Settings.

share|improve this answer
    
I tried that but then I don't have any DNS entries for the servers I am trying to connect to. –  Mitchell Skurnik May 2 '12 at 20:28
    
But it works if you use the IP address? –  fstx May 3 '12 at 4:29
    
THe PPTP server can send a name server address for the connection. You can check with ipconfig /all if there is one. –  fstx May 3 '12 at 4:32
    
Yeah IP's work but it is easier to remember DNS names rather than IP's –  Mitchell Skurnik May 3 '12 at 4:34
    
Of course, but it relevant to know when trying to help. If the name server IP is there, try the fully qualified name. –  fstx May 3 '12 at 4:44

You need to set up split tunneling. With split tunneling you can direct all traffic destined for 10.10.10.0/8 to use the tunnel and all other traffic to use your default gateway. You are not splitting based on what application you are using but where the traffic is headed. I don't know that you can do specific ports unless you also use some kind of proxy.

Also note that if you don't administer the Cicsco VPN router, you may not be able to this.

share|improve this answer
    
I am the administrator of the router but I see no option for that. I am using the RV180W which is fairly limited compared to the higher end models –  Mitchell Skurnik May 2 '12 at 20:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.