Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7 Ultimate with 'Pentium Dual Core CPU E5200 @2.50GHz' and 'Intel G33/G31 Express Chipset Family' as display adapter. I have 2 GB RAM. When I press alt+enter in cmd or turbo c++, it says "This system does not support Full Screen Mode". I am using 1600 * 900 screen resolution. Can anyone tell how to solve this problem.

share|improve this question
    
You're trying to use a program from 1991. In an operating system released in 2006. I personally wouldn't expect it to work at all, so you're kinda lucky. In fact, since it's most likely a 16-bit program, it probably won't work in 64-bit versions of Windows. You could try an emulator such as DOSBox. I would kinda recommend using a newer C++ compiler/IDE, though. –  Bob May 1 '12 at 10:23

2 Answers 2

up vote 0 down vote accepted

Install DOSBox

You will be able to get fullscreen. You will also be able to use TurboC graphics libraries

EDIT:

Also, you are using Windown 7 Ultimate

If you have enough bandwidth, install Windows XP mode. Its perfect for your needs

share|improve this answer

Unless you give up Aero desktop experience and change the WDDM driver (Windows Vista Display Driver Model) to Windows XP compatible display driver, there is no easy way to enable a real, windowless full screen command prompt in Windows 7

Source: here

There is a trick mentioned further down the page that explains how to open CMD maximised each time.

1) Create a shortcut to cmd.exe and double click to open it.

2) Type wmic and press ENTER to get Windows Management Instrumentation Command-line utility running into an interactive mode.

3) Click the maximize button to get a real full screen window of Command Prompt. With Windows 7 default installation setting, you can also click the Command Prompt window title bar and drag it up to the edge of Desktop to get the same maximized window.

4) Right click the maximized Command Prompt window title bar and select “Properties”. In the Properties dialog box, tick the “Quick edit mode” check-box followed by clicking OK button. This step makes Windows 7 “remember” to maximize Command Prompt to this particular full screen window mode, each time you double click the cmd.exe shortcut created in step 1!

5) Close the Command Prompt window (by click the X button or execute exit command twice to exit from WMIC as well as cmd.exe).

Now, double click the same cmd.exe shortcut again, you should see Windows 7 open Command Prompt in the same maximized, full screen window mode again :-)

share|improve this answer
    
Hey thanks, the trick works ! You are a Genius. But there is another problem. I have Turbo C++ 3.0 and I want it to run in the FUll SCREEN. The solution you provided works for Command Prompt only, but not for Turbo C++. You've got solution for this too, I guess. Please let me know. –  Ravi Sharma May 1 '12 at 9:24
    
Run turbo C in the command prompt. –  pjc50 May 1 '12 at 14:24
    
I checked a website, I'm afraid the genius title may be a bit premature :-( –  Joe Taylor May 1 '12 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.