Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OK here is the problem. I use my primary computer to connect to the internet using a SureCom NIC.
i also have a secondary NIC which i connect to a wireless router and share the internet with other laptops in the house.
The problem now is that the computers on the network cannot access my primary computer for homegroups and the such. any help is much appreciated.
ps: this started from when i've shifted to Vista and windows 7.
The LAN connection shows as "Unidentified network"

share|improve this question

2 Answers 2

I bet you have the route's Internet port connected to the primary computer. But that's a mistake. The Internet is on the other side of the primary computer. You have connected the router to the LAN side of the primary computer.

Essentially, you've asked the router to treat the link to the primary computer as a link to the Internet, even though it isn't. So that's what it's doing, even though you don't want it to.

Since you're using the primary computer as a router, you need to stop using the router as a router too. Use the router as a bridge (a bridge connects segments of the same network):

  1. Turn off the router's DHCP server.

  2. Don't connect the router's Internet port to anything. Connect the primary computer to one of its LAN ports.

  3. Set the router's LAN IP to a valid IP for the ICS network but one outside its DHCP range, such as 192.168.0.250.

  4. Reboot all the computers except the primary. (Or do an ipconfig /release if you know how to.)

share|improve this answer

David explain very well you situation right now.
But you can do better and put the Internet connection directly into the wireless router.
Since it is a wireless router this means is fairly new (max 3-4 years old) so it supports most of the Internet connection configurations on the market (cable modem, ethernet, DSL)

You can do it like this:

  1. Take your Internet connection cable (usually it comes from your cable modem or your DSL modem, or even if you're lucky, it comes from the optical fiber transceiver). As you mentioned, it is an ethernet cable since it enters one of your NICs;
  2. Put it into the wan port of the wireless router;
  3. Connect your computer to the router using an ethernet or wireless connection;
  4. Enjoy file sharing and protection from router firewall.

This configuration avoids the windows ICS and other various security risks because of connecting Windows directly to the Internet.

share|improve this answer
    
Well the problem is that the router doesn't support PPPOe dial up. so i have to use the internet facing router as a bridge and then use a dialup from windows 7 –  Sam May 3 '12 at 7:41
    
I'll probably do this when i get a new router. Thanks –  Sam May 3 '12 at 7:56
    
Can you give more details about the router? –  coz May 14 '12 at 7:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.