Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

http://localhost isn't responding for extended periods of time (stopped waiting after 10 minutes), nor are any of my vhosts.

I've tried looking at the error logs and I don't see any entries since 2010 and I use my vhosts daily. As far as I know, I haven't changed any apache settings, everything looks fine with the hosts file, httpd.conf and httpd-vhosts.conf. In fact, there has been no modification in these folders in months. It's possible an automatic update or a recent update to LogMeIn could have done something elsewhere in the windows environment.

I'm restarting apache via:

MyPath\Apache2.2.17\bin\httpd.exe -k restart

and seeing no errors in the command console and as I mentioned, the apache logs are not updating

Two questions: 1) Any idea why the logs aren't populating? 2) What steps could I use to troubleshoot this issue?

UPDATE:

I found the apache logs were populating, just under wamp/logs and not the log files under the apache folder. Every time I restart apache I get a few thousand of these:

[Sat May 05 13:30:26 2012] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 9532: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

I tried adding

Win32DisableAcceptEx

to my httpd.conf file and the errors have changed but they are too numerous to list. What could have changed to have caused this?

share|improve this question
add comment

2 Answers

It's wsock32.dll under system32 folder which is corrupt, probably by some rootkit or application, try booting machine with Windows CD and replace the file, the issue will get solved

share|improve this answer
    
Can you elaborate on how wsock32.dll could be causing this problem? –  DragonLord Oct 11 '12 at 5:32
    
I never found a resolution to this problem and have since reinstalled my os and everything is working fine. Apologies to anyone having this problem later, I never found a working solution and am no longer able to test suggestions. –  Shane Oct 12 '12 at 13:32
add comment

check your

c:\windows\system32\drivers\etc\hosts

file. check there is a line without " # ".

127.0.0.1 localhost

If not present, update and try again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.