Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason, multiple laptops on our wifi network often lose the ability to print to a device attached to a server on the network. Restarting the Print Spooler on each laptop fixes the issue. However, restarting the Windows Print Spooler service (via either services.msc or via the net start/stop command) requires administrative privileges.

Is there a way to allow standard users to restart their local print spooler service without requiring elevation or administrative privileges? For example, via a policy change?

share|improve this question
try secpol.msc local security policy i beleive they changed the shortcut in Win7/Vista but im sure it would be easyt o find – dc5553 May 1 '12 at 16:16
The sc command allows you to change the permissions on a service. I believe the options are sdshow and sdset. The SDDL syntax is documented here:… – Harry Johnston May 2 '12 at 2:35
sc sdshow spooler shows service permissions. Need to decipher SDDL syntax to make changes. – sean e May 2 '12 at 15:05
up vote 9 down vote accepted

I ended up using Method 3 at How to grant users rights to manage services in Windows 2000.

  1. Download and install SubInACL.exe
  2. run "C:\Program Files\Windows Resource Kits\Tools\subinacl" /service Spooler /grant=<username>=TO

SubInACL works on Windows 7.

The T grant parameter is for start service access and the O parameter is stop service access.

Now <username> can:

  • run sc stop Spooler and sc start Spooler
  • run net stop "Print Spooler" and net start "Print Spooler"
  • use the Restart button on the Print Spooler item in services.msc
share|improve this answer
Awesome. As an admin, I've been remoting to a user's PC to do this over and over and over and... but no more, thanks to you! – ThisClark Mar 10 '15 at 16:14
Whoops... when I tried this (elevated) for the service MySQL I got "MySQL - OpenService Error : 5 Access is denied" – mike rodent Mar 14 at 21:16

Try: SetACL: Windows ACL management

SetACL + GUI = SetACL Studio

share|improve this answer
Welcome to Super User! This answer doesn't explain how the software solved the user's problem. Compare to the other answer. We have recommendations on our meta site on how to write great software recommendations, please take a look. – Daniel Beck Sep 28 '12 at 7:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.