Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know that someone recently asked a very similar question, but I tried all of the answers that showed up under that question, and nothing seems to have worked for me.

I am trying to set up Home Sharing between two computers. One is running Windows XP, the other is Vista. I do not have a firewall installed, and I do not believe that I have a router firewall.

The two computers are mine, and my girlfriends. I made sure that her computer was authorized to my account, and I authorized my computer to her account. I have tried setting up the home sharing thing using my account information, and using her information, and each time, the sharing icon disappears, and nothing happens. I've verified that both computers are set to check for shared libraries, and I've made sure that both computers are set to share their libraries.

I've tried restarting Itunes after enabling Home Share, and I've also tried restarting both machines. Is it just not possible to share between XP and Vista, or is there something that I may have missed? When I check under preferences, I can see that sharing is on, but there are no users connected. I'm at a loss as to what else to try. I have made sure that both computers were actively running Itunes, and double checked that neither computer was sleeping, and nothing has helped.

share|improve this question
    
i think this is the related question, for those wondering: superuser.com/questions/38701/… ... –  quack quixote Dec 30 '09 at 6:10

1 Answer 1

OK, here's what I did:

This works on 2 (and probably more) Macs—

without messing around with any port settings with OS X Preferences, Sharing, File Sharing turned OFF on BOTH computers with iTunes Preferences, Sharing, "Share my library on my local network" turned OFF on BOTH computers

(apologies for documentation overkill—just being thorough)

  1. Turn OFF Home Sharing on BOTH computers (this is NOT done in Preferences; instead, go here: Advanced, Home Sharing)

  2. Make sure BOTH machines are authorized for BOTH iTunes accounts (Store, Authorize Computer)—i.e., if each has its own iTunes account

  3. You do NOT have to be logged into the same account on both computers; each computer may stay logged into the iTunes store under its own login

  4. For sanity's sake on this part, check to make sure of this—i.e., that each machine is logged into the store with its own store account (Store, View My Account, check to see ID is correct)

  5. NOW turn Home Sharing back on (Advanced, Home Sharing) on each computer, but use ONE account to log into Home Sharing on both (or all) computers

  6. DON'T WORRY, this does not "flip" the login ID for a particular computer's iTunes Store connection to the ID being used for Home Sharing

  7. On each computer now you should see a "Home" icon with the shared library in the left-hand sidebar

  8. Open the shared library and drag and drop as desired

The bottom line seems to be this:

  1. Keep each computer logged into the store with a separate iTunes ID (if you need to)
  2. Get all the computers authorized for all available IDs
  3. Use ONE ID to log into Home Sharing on ALL computers

You will of course ONLY see the Home Sharing icon pop up if both computers are on, with iTunes open on each

You'll know that this whole thing is working if the shared library listed on the left has the correct "Home" icon (and not the blue, "shared" icon that shows up when Preferences, Sharing, "Share my library on my local network" is turned on—yes, this is the one you see in Internet cafes filled with Mac users)

I've tested the above over and over again, even completely rebooting my two machines (they have different iTunes accounts), and it still works. This is running Leopard on both machines.


MBP 2.4 GHz Santa Rosa 17-inch 4 GB RAM 320GB HD 1920x1200 matte Airport Extreme; Airport Express x5; iPod G5 60GB x2; iPod Shuffle x2; iPhone 2G 8GB

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.