Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running Windows 7 (RC, 64 bit). Suddenly, today, after months without a problem, clicking on links has become extremely slow.

I've noticed this in two places.

(1) clicking hyperlinks in Outlook email messages, which launches Firefox, takes around a minute. Launching Firefox by itself is instantaneous - I have an SSD drive and a very fast CPU. (2) opening Word documents attached to Outlook email messages also takes a surprisingly long time.

The only thing these two might have in common is that they use the DDE mechanism, if I'm not mistaken, to send a DDE open command to the application. Under Windows XP this problem could sometimes be fixed by unchecking the "Use DDE" checkbox in the file type mapping, however, I can't find any equivalent under Windows 7.

See here for someone else having what I believe is the same problem. See here for more evidence that it's DDE being super-super-slow.

share|improve this question
    
Maybe monitoring outlook.exe with Process Explorer could yield some interesting information: technet.microsoft.com/en-us/sysinternals/bb896653.aspx –  John T Sep 16 '09 at 2:55
    
will try next time this happens –  Joel Spolsky Sep 16 '09 at 3:17
    
I've observed something similar on XP, where opening any type of file via DDE seems to hang Explorer for about 15 seconds. I'm pretty confident that Outlook 2007 has been causing this, since the problem goes away if I close Outlook entirely. When I restart Outlook the problem doesn't recur immediately, but within a few minutes it's back to doing the same thing. –  Charlie Oct 3 '09 at 19:55

8 Answers 8

up vote 4 down vote accepted

I'm getting a little bit closer.

Rebooting fixed the problem. :) Not that that is a permanent solution...

According to Microsoft programmer Raymond Chen, DDE is supposed to be obsolete, but everybody seems to still be using it.

The trouble with DDE, he says, is that it's cooperative, and one hung application can cause all other applications to not respond properly when they try to use DDE.

In my case, rebooting fixed the problem because it closed whichever application it was that was failing to respond properly to the DDE messages.

A common solution to this problem in the Windows XP timeframe was to uncheck the USE DDE box in the file type handler, but that checkbox appears to no longer exist in Windows 7. Even though DDE is obsolete, applications still register it in the registry so stupid apps like Outlook 2007 still use it to launch hyperlinks.

This solution wasn't very useful, because even stupider apps, like Firefox, were so intent on using DDE that they would REREGISTER themselves as using DDE every time they launched. The only permanent solution was changing the security settings on the appropriate key in the registry so that Firefox didn't have the ability to write to it.

I'm still not very happy with this answer.

share|improve this answer

I had a similar problem not too long ago, and the issue was definitely with Outlook, it became dead slow opening links and attachments. in my case it was the PST file which had grown beyond 4 GB.

Try compacting your PST or OST file:

  1. Tools | Account settings
  2. Click on the Data Files tab
  3. Select your mailbox and click Settings
  4. [Exchange mode] In the Advanced tab, click on the Offline Folder File Settings
  5. Click Compact Now

MSKB has a few more tips: How to troubleshoot performance issues in Outlook 2007

share|improve this answer
    
I'll try compacting the offline file... in my case it's an OST and it's only 1GB. –  Joel Spolsky Sep 16 '09 at 2:21
    
ZOMG, that was it! Compacting the OST file fixed it!!! –  Joel Spolsky Sep 16 '09 at 2:23
    
edited to add specific instructions in case someone finds this in the future –  Joel Spolsky Sep 16 '09 at 2:27
    
AAH! I spoke to soon. This didn't fix it. The reasons I thought it did are too embarrassing to mention here. :-D I really think it is somehow related to the DDE mechanism, because in the past, this problem could be fixed temporarily by deleting the DDE entries that Firefox put in the registry –  Joel Spolsky Sep 16 '09 at 2:38
2  
well, at least your outlook storage files received some free maintenance in the process :) –  Molly7244 Sep 16 '09 at 2:42

If somehow Internet Explorer is slow, then clicking links from Office will be slow as well, even if you don't use Internet Explorer as your default browser. So: check if Internet Explorer is still running fine.

Though you seem confident that DDE is to blame, Office has a surprisingly odd feature: it first uses an Internet Explorer component to see if the URL one clicks is valid. It does not identify itself as Internet Explorer; in the access logs one might see:

User Agent: Microsoft Office Existence Discovery

After that, it hands the resulting URL to the default browser. That is:

  • If the hidden call to the URL yields some redirect, then the default browser is not even given the original URL, but the redirected URL.

  • If the web site for some reason blocks the User Agent "Microsoft Office Existence Discovery", or if your Internet Explorer settings somehow prevents proper access to the site, then the link might seem dead while in fact using a normal browser it would work fine.

Ever wondered why your browser keeps redirecting you to some login page when clicking links from Office? Right: if Internet Explorer is not authenticated at the web site, then some sites might respond with a redirect to a login page, making Office forget about the URL you actually clicked... :-(

Some more details about this funny annoying "Microsoft Office Protocol Discovery" at Microsoft's How documents are opened from a Web site in Office 2003. A similar process is used for Office 2007.

share|improve this answer

Old question, I know, but here goes... After trying a couple of other suggestions, I finally fixed the problem by running a repair-install on Microsoft Office.

All the launched-by-DDE programs (FireFox, Excel and others) are now launching normally without the delay.

share|improve this answer

I'm running XP with Office 2007. I had initially tried the many solutions discussing use of "%1" and disabling DDE in various file extensions, but it only seemed to work for those extensions selected and only when they were launched from certain locations. (I.e. lauches from my Quick Launch toolbar and Outlook didn't always speed things up.)

I tried all of the solutions below when I expereinced the same problem. One of them seems to have worked, though I'm not sure which one it was. I never did identify the root cause, though the problem first occured in the midst of some backup work I was doing involving an external drive and also while I was opening a rather old Outlook pst file. At one point shortly before noticing the problem, I experienced some sort of (ODBC?) error while trying to export an old Outlook calendar. I'm suspicious that one of these actions may have been related.

  1. Start menu | Run | Cmd | chkdsk c:\ /F (Opted to restart terminal when solution presented itself, though I tried solutions 2 & 3 before actually restarting).

  2. Verified that Network DDE and DDE DSDM were disabled in my services (they already were).

  3. Verified that I hadn't installed anything new recently that might be interfering (I hadn't).

  4. Start | Settings | Control Panel | Set Program Access & Defaults | Custom | Selected my options (I use Outlook for email and Firefox as my browser). When I did this, Microsoft repaired something. At this point, I did my reboot (from option 1) and after chkdsk ran, things came back up just fine.

I also read that some people had success after performing a repair reinstall of Office, but I was going to use this as a last resort option, as I didn't have the disks at hand.

Good luck.

share|improve this answer

I have tried all of the suggestions above with no success. It's very frustrating to wait one full minute after clicking a hyperlink before it displays in Firefox. And if you click more than once, every click displays as a different tab.

So here is my workaround, which works but is still annoying.

When you want to activate a hyperlink:

  1. Right-click it - do not left-click since that will launch your 60-second wait;
  2. Copy the internet URL address shown, and then
  3. Simply paste the link into your browser and press Enter. Your page instantly appears.

This works every time because you are bypassing the bug in Outlook somehow preventing us from connecting directly.

share|improve this answer

This answer is somewhat related to your issue and may give you a clue to look some place else for the fix. Have a quick read at: http://support.microsoft.com/kb/929867 Good luck.

share|improve this answer
    
this doesn't work, because the "Use DDE" checkbox of which they speak is not in Windows 7 –  Joel Spolsky Sep 16 '09 at 15:11

I have to do the following to fix this problem:

  1. Set Internet Explorer to default browser (on my system I actually have to use Safari to set IE to default strangely enough)
  2. Reboot
  3. With Firefox set to check if it is default browser, open Firefox and choose Yes to set it as default browser.

I have to do this once a week and I haven't figured out the larger reason for this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.