Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Lacie Quadra hard disk MAX external hard drive has stopped being recognized by my PC after a year. I tried everything and ended up opening the casing and extracting the two 1TB hard drives that come inside.

They are set up in a RAID-0 array (when assembled in the casing). I plug them both in my MoBo, and only one of them is recognized (the master) as a 2TB drive, the other one is required to be formatted and assigned with a drive letter, but I know this will delete my info, since a RAID-0 arrange splits the data between those two.

I was told I could get my data out by using Ubuntu (which I'm using now), but I do not know what steps to take in order to at least be able of seeing my files again.

I can see both disks in Ubuntu's disk utility, and it says the same: only the master disk is recognized as a 2TB one, the other one is stated as "unrecognized".

It was effectively in raid 0. I used the "Raid recovery" tool, but I still needed to find out the stripe size (which after a lot of research was set to 64kb). It did recover some things, mostly deleted files and non-important files. It never recovered the "arrange" itself, and everything was organized in such a weird folder structure.

I'm still researching about the mdadm Linux functionality, but I've had no luck so far.

share|improve this question

1 Answer 1

LaCie 2Big drives are nearly always set up as JBOD, not RAID. The second drive is concatenated onto the end of the first drive.

I've used http://www.diskinternals.com/raid-recovery/ (US$250) to recover 2Big spans before with complete success. There's a trial available that will at least allow you to see the drive tree.

You can use dmraid in Linux to recover data from a failed span, but I'm not familiar with the usage.

You may also have success buying another JBOD enclosure and using the drives in it, but I would consider that a last resort, as it will likely reformat the drives (though data recovery in that case is substantially easier).

share|improve this answer
    
Thank you so much for the response. I've tried diferent types of RAID rebuilding software, but the problem is that my discs are not recognized as two separated units. Only one drive is recognized. Whenever I try to use that type of software there are two problems I bump into: 1.- They ask me to add the path of the two drives (and I have only one), or 2.- they ask me for a ".img" file for each drive, which I do not know how to create/retrieve. I will try to research about the dmraid functionality though. Thanks a million for taking the time to answer. –  Gustavo May 2 '12 at 0:12
    
Just to Clarify one point. I've checked the box, and it says it comes in either RAID 0 or RAID 1 array (it has a tiny switch that allows you yo choose between both). I could see the full 2tb, so I take it I always had it in RAID-0. –  Gustavo May 2 '12 at 0:38
    
You'll probably need to Initialize the drive in Windows, but you don't need to have a drive letter assigned. The Diskinternals software should show the physical drives to you. If the external device was an actual RAID0 enclosure, you wouldn't be able to see any partitions. If RAID1, you'd see your data regardless. For dmraid, the path it wants is the physical device path (/dev/sd* or /dev/hd*) –  EKW May 2 '12 at 14:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.