Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having the same problem I see posted by skerit. When I'm at home, my Macbook Pro (2008, OS 10.5.8) connects to my router fine. When at my girlfriend's it's suddenly stopped connecting. I get a message in Network Prefs that "Airport has a self assigned IP address and may not be able to connect to the internet." Her Macbook Pro (also 2008) is connected just fine. Another friend's newer Macbook Pro also connects with no trouble. Mine used to and the only thing that's possibly changed is that I had the logicboard replaced by Apple about two weeks ago. I have no idea if that would have had any effect. I can NOT do a software update as someone suggested in response to skerit's question because I only have about 4 GB of space left and am counting the time until the new Macbook Pro is released so I can upgrade. Someone mentioned renewing the DHCP but I have no idea how to make that happen. Any help will be SO greatly appreciated...this has stopped me from being able to work when in that location. Win

share|improve this question
    
Can you link to this post by skerit? –  dsolimano May 2 '12 at 2:46
    
I have added it. –  Kyle Jones May 2 '12 at 4:48

3 Answers 3

It appears to be connected to Keychain, and remembered settings for this particular network... and for you, the fact that while your hardware changed, your settings did not.

In everything I can dig up, there appear to be two overlapping solutions.

The easy and first solution to try is this.

  1. Turn off Airport
  2. Switch off the built-in firewall (found in: System Preferences>Security>Firewall), and set it to allow all incoming connections.
  3. Turn Airport back on again

The second solution involves deleting the files that contain the settings themselves. They will be recreated once you wish to connect to these networks.

  1. Go to Mac/Library/Preferences/SystemConfiguration
  2. Delete the following: a. Com.apple.airport.prefrences.plist b. NetworkInterfaces.plist c. Preferences.plist
  3. Shut down computer
  4. reset PRAM

Some have had success reconnecting without shutting down the Mac.

So, try the first solution... and if no joy, try the second one. Most people that had this issue out there ended up doing both.

share|improve this answer

You mentioned that you don't know how to renew DHCP leases, so on the off chance that fixes the problem:

  1. Go to System Preferences -> Networking and click on Airport in the left column.
  2. If the padlock on the lower left isn't open, click on it and authenticate as an administrator.
  3. Click on "Advanced".
  4. In the new window you should see a "Renew DHCP Lease" button on the right. Click on that and see if you are assigned a proper IP address for the local network.
share|improve this answer

Not much to add, but it never (rarely) hurts to reboot the wireless router — if you can get to it. Sometimes the DHCP server get wonky.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.