Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Suddenly my Win 7 machine is unable to ping by name an XP machine on the LAN, but by IP number it works.

What could be the problem?

The Win 7 machine is connected to the router wirelessly, but the XP machine is connected by cable to the router.

share|improve this question
    
Need more info: how does it know the name in the first place? Does your machine have an entry in the hosts file, or does the router have DNS for the LAN? – Theo May 2 '12 at 11:14
    
When I ping the Win 7 machine name from itself I get: Reply from fe80::1004:a8b0:9e40:a42c%10: time<1ms Reply from fe80::1004:a8b0:9e40:a42c%10: time<1ms instead of a normal IP address. What does that mean? – CJ7 May 2 '12 at 11:27
    
That's IPv6. If you look at your Network Adapter, you'll see IPv6 turned on. That has nothing to do with the name. – Theo May 2 '12 at 11:29
    
But when I ping other machines I get a normal (IPv4?) address. Why aren't I getting a normal IP address for my own machine? – CJ7 May 2 '12 at 11:33
1  
Yes, exactly. Pinging using netbios name will only work within the same workgroup/domain (in the absense of proper dns setup) – Paul May 4 '12 at 4:51

I have solved the problem and I offer the following in case it might help people with the same issue:

First I went into the WINS tab inside the TP/TCP settings of the LAN connection and enabled NetBIOS.

Then I did ipconfig /flushdns from the command prompt.

I then changed the NetBIOS setting back to default in the WINS tab.

The problem has gone away now, but I don't know exactly what had fixed it.

EDIT: Another thing that can fix this issue is making sure both machines are on the same Workgroup.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .