Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to set up FTP on my Linode server, using Pureftp.

I only have the root user at this point on the server, but Filezilla doesn't let me connect with the root user. Why is that?

I then created a new user and gave it the same privileges as root via visudo, now this new user can delete files from its own directory but not from other directories. How can I change that? Thanks

share|improve this question
    
Well, have you checked if there's any option in Pure-FTPd relating to root access? I'm sure this is disabled as a security feature. –  slhck May 2 '12 at 14:50
    
That would explain why I cannot connect using the root user. Thanks. How about changing the configuration to allow an added user to be able to upload into any directory? –  drtanz May 2 '12 at 14:58

2 Answers 2

up vote 1 down vote accepted

You are using Pure-FTPd in a way it is not meant to be used. You also are not aware of basics about file permissions. It sounds like you would much rather just use SFTP over SSH in practice.

Just set up SSH on the server (which you very likely already have done) and connect via SFTP, e.g. directly through Filezilla. If this is how you always access the server, you will not even notice the difference. Depending on configuration you can allow root to log in over SSH, though it is often discouraged for security reasons.

share|improve this answer
    
That's what I needed, thanks for the explanation. –  drtanz May 2 '12 at 22:44

The blocking of "root" access to FTP is most likely a security restriction at the server end in the FTP deamon (ftpd). It is almost certainly not a restriction in your FileZilla FTP-client application. It is a bad idea to allow root FTP access because FTP passwords are passed over the network in plain text and are not encrypted - curious strangers can easily get root access to your server. (you should probably be using ssh and scp or sftp instead)

The reason your new user cannot delete files from other directories is that the new user does not have write permissions on those directories. If you want a stranger sniffing your network to be able to delete everything in a folder just give new user write permission on that directory, typically by changing the group of the directory to one that new user belongs to (chgrp groupname directoryname) then setting permissions (chmod g+w directoryname) Note that this may cause problems with other applications and is inadvisable for any directories outside user's home directories unless you really know what you are doing.

So far as I know sudo and visudo have no effect on permissions when using FTP.

share|improve this answer
    
This enables me to understand better, thanks. –  drtanz May 2 '12 at 22:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.