Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Context:

  • ThinkPad T400
  • Intel WiFi chipset
  • Pacific Surfliner (LAX to SAN route)
  • Windows 7

When I try to connect to the WiFi network on-board, this is what I get:

  • Speed: 65.0 Mbps
  • Signal Quality: All the bars are green
  • IPv4 Connectivity: No Internet access
  • IPv6 Connectivity: No Internet access

When I tried looking at the details, there was no IP address assigned to my computer.

I tried running the IE9/Windows 7 networking diagnostics and the computer wasn't able to fix the problem.

I also tried disabling and re-enabling my wireless chip using the ThinkPad's physical switch.

What can I try to get an IP address? Should I just hope that the problem goes away on its own?

share|improve this question

closed as too localized by iglvzx, slhck, Nifle, Sathya May 20 '12 at 9:13

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are your IPv4 settings set to automatic? –  iglvzx May 3 '12 at 6:09
    
Yes, they are. <filler> –  Zian Choy May 7 '12 at 1:07

1 Answer 1

up vote 1 down vote accepted

Can anyone else in your area get Internet access on that network? It's probably just that the network is broken. Ask a conductor or other Amtrak employee about the problem.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.