Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to create new users on my Media Temple (dv) 3.5 who have the same access as a beta account. The reason for this is so my development team can use GitHub for source management without breaking permissions and such.

I was able to figure out how to create the users, but when I try to connect to GitHub using ssh -vT I'm getting an error.

The home directory I've created is at /var/www/vhosts/beta.domain/web_users/username -- when I log in, cd ~ puts me in the right place.

However, when I try to connect to GitHub, it's looking for .ssh/ at /var/www/vhosts/beta.domain/.ssh instead of /var/www/vhosts/beta.domain/web_users/username/.ssh

I used this command to create the user:

useradd -d /var/www/vhosts/beta.domain/web_users/username -m -ou 10001 -g psacln -s /bin/bash username

Have I missed a step? I've only been dealing in the command line for a short time, and this is my first time dealing with new users. Any help is hugely appreciated.

Thanks in advance!


Here's what I'm finding in $HOME:

[username@beta.domain ~]$ echo $HOME

This is the output from ssh -vT

OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to [] port 22.
debug1: Connection established.
Could not create directory '/var/www/vhosts/beta.domain/.ssh'.
debug1: identity file /var/www/vhosts/beta.domain/.ssh/identity type -1
debug1: identity file /var/www/vhosts/beta.domain/.ssh/id_rsa type -1
debug1: identity file /var/www/vhosts/beta.domain/.ssh/id_dsa type -1
debug1: loaded 3 keys
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-5github2
debug1: match: OpenSSH_5.1p1 Debian-5github2 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
The authenticity of host ' (' can't be established.
RSA key fingerprint is aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa.
Are you sure you want to continue connecting (yes/no)? yes
Failed to add the host to the list of known hosts (/var/www/vhosts/beta.domain/.ssh/known_hosts).
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
Connection closed by
share|improve this question

Check if $HOME is set to /var/www/vhosts/beta.domain. If so, figure out where it set.

You could download the source code, build it and run it under a debugger.

share|improve this answer
Here's what I'm finding in $HOME: [username@beta.domain ~]$ echo $HOME /var/www/vhosts/beta.domain/web_users/username – jlengstorf May 3 '12 at 14:34
Download the source code, build it and run it under a debugger. That's the only thing I can think of. – fstx May 6 '12 at 4:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .