Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a monitor with a native resolution of 2560x1440, connected through display port.
I also have an AV Receiver connected to the video card via HDMI, to have surround sound in games. All using Radeon HD 5670 (will upgrade soon to HD 7850).

The problem is that my computer detects the receiver as a separate monitor, with the highest available resolution of 1920x1080. I have 3 options:

  • Disconnect the second display. But then the sound (digital audio output through video card) also disappears.
  • Duplicate displays. But then my primary monitor resolution is reduced to a maximum of just 1920x1080, that being the maximum of the second monitor.
  • Extend desktop. This is the solution I picked so far, it being the least evil. The problems I face in this situations are 2: I have a blank part of the desktop where I sometimes lose my mouse pointer, so I made the extension small, 640x480, and placed it in a corner; when I turn off the main display, all windows resize to 640x480.

In Kubuntu I had the option to duplicate the displays, while keeping the higher resolution. Which was great. I tried overriding using the Win7 netbook hack, but it's not available on non-netbooks.
Is there a similar solution for this problem in Windows 7?

share|improve this question
    
Related to this, I would also be interested in using just the audio port, without displaying anything in the second screen –  clabacchio May 3 '12 at 9:34
    
That would be golden. However closest I came to that was on Kubuntu. –  AlexanderMP May 3 '12 at 9:48
add comment

1 Answer

In Catalyst Control Center, go to external monitor properties and disable using EDID for supported resolutions. Then you should be able to force a higher resolution for the receiver, and use duplicated display.

share|improve this answer
    
I found no such setting. in fact I've played with all available settings in CCC and nothing enabled me to enable a higher resolution. –  AlexanderMP May 5 '12 at 8:11
    
@Alexander Perhaps it depends on the CCC version, then, and/or the interface used for connecting the display. On my laptop, with a monitor hooked up by VGA, that option is available. If it doesn't show up for you, then I'm out of ideas, sorry. –  Indrek May 7 '12 at 13:46
    
I see. I guess it's because I use digital connections, which have to know what you have on the other side. DP and HDMI. HDMI is a troublesome port from what I've read. –  AlexanderMP May 7 '12 at 13:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.