Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo W500 Laptop with an ATI FireGL 5700 card and it has VGA and a Display Port.

Everything works fine if I boot my laptop with a monitor already attached. Sometimes it also works if I attach a monitor afterwards. But there are problems after hibernate or sleep mode.

If I use a monitor via VGA, then activate hibernate or sleep mode, unplug VGA and attach a different monitor via Display Port the resolution is correct but the Hz is wrong and I cannot select the right one as there is no such option. I have a strange monitor that uses 59 Hz instead of 60 (at least that is what Windows tells me). If I select 60 Hz the screen gets smaller and I get the effect of watching widescreen movies on a 4:3 monitor (black border). But even if I try to change the resolution there is no option for 59 Hz.

I have no problem if I need to readjust my resolution, but how can I force Windows to recognize the correct or optimal monitor settings so I can select them? I do not want to reboot my laptop every time.

I am not sure if the problem is the hibernate or sleep mode, as the two monitors are not in the same location, one is at home the other one in my office.

share|improve this question

1 Answer 1

In the Screen Resolution control panel, click the Detect button. That should force Windows to redetect the monitors and their supported resolutions and refresh rates.

enter image description here

share|improve this answer
    
Tried this, but still does not work. –  ayckoster May 3 '12 at 13:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.