Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm working with a fresh install of Lion - including wiping the hard drive - but Spotlight refuses to be enabled. I've tried:

  • Unloading and loading the MDS service
  • The following commands:

    sudo mdutil -a -i on
    sudo mdutil -i on /
    sudo mdutil -E /
  • Looking for hidden "no index" files (none found)
  • Repairing disk perms
  • Checking logs for any hints as to what might be preventing Spotlight from enabling

Nothing seems to allow me to enable Spotlight on the root drive. I am continually returned:

     Indexing and searching disabled

Does anyone know what would prevent Spotlight from enabling or how to further diagnose the issue?

share|improve this question
Install Alfred and see if that kickstarts it somehow. You could also try Repair Permissions in Disk Utility. – user3463 May 3 '12 at 15:29
Randolph, Alfred relies on Spotlight, so no go there. And tried disk perms too. – Matt Schultz May 3 '12 at 17:45


The machine had its NVRAM forced to safe mode. Zapping PRAM (CMD+OPR+P+R on boot) cleared this, and it now works.

Incidentally, Lion did nothing to overtly indicate that it was booting into Safe Mode, which would've really helped in identifying and fixing the issue.

share|improve this answer

Do you maybe have a /.metadata_never_index file at the root of the volume? A similar question at Ask Different: Spotlight reports "Indexing and searching disabled" in Lion.

share|improve this answer
I checked for all hidden files; none existed. =\ – Matt Schultz May 3 '12 at 14:08
That was the issue for me, thanks. – Tony Eichelberger Apr 18 '13 at 16:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .