Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running a virtual machine (Win XP, but OS doesn't really matter) on my Windows 7 PC using the loopback adapter to create a private network between my host computer and the virtual machine.

However, unfortunately communication between my virtual machine and my host machine is restricted by Windows Firewall (e.g. I can't communicate over port 80, etc), because Windows 7 says the network on the loopback adapter is unidentified, and thus its default profile (e.g. network location) is public. To make matters worse, there is no way to change the profile of the network!

How can I force Windows to allow me to change the profile of the loopback network, so that I can change it to private and thus communicate between the vm and the host under the more permissive private Windows Firewall profile?

share|improve this question

migrated from May 3 '12 at 23:52

This question came from our site for professional and enthusiast programmers.

After looking at a number of different solutions online, hopefully here is a permanent solution.

Based on this post,, it seems that the way that Windows 7 identifies networks is by the MAC address of the gateway the adapter uses.

So basically we need to configure the loopback adapter on the host to use a gateway that will point to a machine or device with a consistent mac address. That is the key.


  1. Pull up the properties for the loopback adapter on your machine.
  2. Pull up your IPv4 settings and instead of using "Obtain an address automatically" give the host machine a static ip -- something like
  3. Set your subnet to something like; and set your gateway to the IP that you will give the virtual machine -- something like
  4. Do the same on the virtual machine, but this time flip it. So the IP on the virtual machine would be and the gateway would point to your host, or
  5. You may need to disable / reenable the adapters on both machines before Windows 7 realizes it now has a mac address to identify this network with.

Since Windows 7 is relying on the mac address of the virtual machine to identify the network, your virtual machine will need to be running and then you can try to disable / reenable the loopback adapter on the host machine to try to force Windows 7 to update itself. Once Windows 7 sees the mac address on the virtual machine, you should be able to change the network profile / network location.

Whenever you restart your machine, you'll again of course need to disable/reenable your loopback adapter after you've started the virtual machine. (When the host machine first comes up, since your virtual machine is not running, Windows 7 things that once again it's on a network with a different gateway mac address. This is annoying. But following the above instructions to start the virtual machine and disable/reenable the adapter on the host, should resolve this each time.)

Hopefully, the next version of Windows provides a better resolution to this issue with the loopback adapter and being able to change the network profile / location.


share|improve this answer
Is there a way to automate this operation using netsh? – CMCDragonkai Jun 16 '14 at 2:10
What if the VM such as Virtualbox binds to the network adapter using bridged networking, does this still apply? – CMCDragonkai Jun 16 '14 at 4:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.