Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My iPhone is synced with my home PC which is all working fine. What I want to do is plug my iPhone into my work mac and have it charge but not do any syncing.

The problem is that when I plug the iPhone into the mac it loads up iTunes. I understand that this is a good default behavior but the only reason I want to connect it is to charge so I don't want to have iTunes open up only to unmount the iPhone and close iTunes.

I have tried in the iTunes preferences checking the "Disable automatic syncing of iPhones and iPods" option but it still happens.

Does anyone know how to disable this behavior? My feeling is that is must be an OS setting not an iTunes one but I am lost as where to look.

share|improve this question
    
And the race was on! lol. –  KronoS Apr 30 '11 at 20:43
    
Answers {1,2,3,4} minute(s) ago! Wow! –  squircle Apr 30 '11 at 20:44
1  
add comment

6 Answers

up vote 6 down vote accepted

If I remember correctly there's on option that says "Open iTunes when this iPod is connected" on the screen which gives details for the connected iPod. Have you unselected this?

enter image description here

share|improve this answer
1  
Where is this option though? I can't see it in the iTunes preferences. –  user11313 Sep 16 '09 at 11:38
    
Connect your iPod and it will appear in the list on the left hand side of the iTunes window. Select it in this list and iTunes will show a screen all about the iPod. The options are at the bottom of this screen. –  Dave Webb Sep 16 '09 at 11:44
    
I just tried this now with my iPhone, and for me it is sufficient to uncheck "Automatically sync when this iPhone is connected". I did not have to disable iTunesHelper in Login Items. –  Jonik Sep 16 '09 at 17:36
    
I just tried this out and it was already disabled... The option below it "Sync only checked songs and videos" was checked though. If I uncheck EVERYTHING then it doesn't sync. Bingo! Thanks guys! –  user11313 Sep 17 '09 at 9:47
add comment

You can also click on the CTRL + SHIFT keys when starting iTunes and keep them pressed untill you get something from the sort of "iTunes is running in safe mode". Then click on the Continue button.

You must keep the ctrl+shift buttons pressed until iTunes detects your iDevice. Then simply untick the “Automatically sync when this iPhone/iPod/iPad is connected” option. Finally click on Apply in order to apply the changes.

share|improve this answer
add comment

If you go into the Preferences of iTunes (iTunes -> Preferences on OS X), on the Devices tab, there is a checkbox that you can select to prevent devices from automatically synchronizing. This still allows you to manually sync the devices should you choose to do so.

Autosync

share|improve this answer
add comment
iTunes->Preferences->Devices->"Prevent ... from syncing automatically"

Or if you want to just disable iTunes from popping up, in iTunes, go to your device, under Options uncheck "Open iTunes when this (device) is connected."

enter image description here

share|improve this answer
add comment

I found a possible answer.

http://docs.info.apple.com/article.html?path=iTunesMac/9.2/en/15517.html

But once I tried it the iPhone appeared to still try to sync so I set iTunes to not sync any device automatically. That worked.

share|improve this answer
add comment

Or open System Preferences -> Accounts -> Login Items and remove the "iTunesHelper" entry.

This is the answer i gave here. Which is basically the same question.

share|improve this answer
    
This is perfect thanks! –  user11313 Sep 16 '09 at 11:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.